Subscribe

Snapdrive issue on Windows Host

Hi

we have installed snapdrive on windows host and tried to rescan for LUNs in snapdrive GUI, issue is we are not able to see any LUNs under GUI.

when I check under disk management i can see my newly allocated devices there.

Re: Snapdrive issue on Windows Host

I had the same issue before.

Did you create the LUN using SnapDrive?   If not, and you created the LUN on the filer, your disk probably hasnt been initialized and has no partition/file system on it.

If the above sounds correct, try iniitalizing the disk in Disk Manager then create a partition on the disk.   Then refresh SnapDrive and your LUN should show up.

If that doesnt work, make sure SnapDrive is configured with the correct credentials to access the filer.

Re: Snapdrive issue on Windows Host

i created 1x50gb and 1x25gb LUNs on filer and assigned those LUNs to Win host.

i can see all the devices (2x50gb and 2x25gb - since dual paths)  under disk mgmt, i initialized them, assigned drive letter.

even after doing this i dont see LUNs under Snapdrive GUI.

also, after adding Filer name, IP add under properties tab, as soon as i do a refresh,

on filer i see the below error msg:

Thu Jul  5 13:09:12 CDT [Filer01: HTTPPool02:warning]: HTTP XML Authentication failed from x.x.x.x(ip add of server).

Re: Snapdrive issue on Windows Host

Great.  Sounds like your LUN's are correctly provisioned to the host as you can see them in disk manager.

It appears that you are having issues authenticating to the filer from SnapDrive.  Make sure your credentials are correct and that you chose the correct transport protocol.  You should also verify your permissions on the filer.  You can view/change your current transport protocol settings by right clicking the host name in the SnapDrive console and choosing "Transport Protocol Settings"

A way to test your "Transport Protocol" credentials is to walk through the SnapDrive "Create Disk" wizard.   You will need to provide the name of a storage system in one of the dialogues you encounter and it will tell you if your credentials are incorrect.  At that point, if your credentials are correct, you can cancel out of the "Create Disk" wizard unless you want to continue and create the disk.  Otherwise, if your credentials are incorrect,  you will need to correct the credentials in the "Transport Protocol Settings" dialogue.

Re: Snapdrive issue on Windows Host

I was having the same issue the other day, I read somewhere (can't remember document) where cifs had to be enabled, so I enabled cifs and I was now able to enumerate disks in SnapDrive.

Re: Snapdrive issue on Windows Host

yup i can see now..

but the issue is.. when i gave my filer root username and password...

under GUI when i go thorugh Create Disk wizard.. i am seeing all my other production volumes.. instead of seeing only these 2 dedicated volumes

Re: Snapdrive issue on Windows Host

That sounds right...especially if you are using a Windows Domain or Active Directory (via RPC) authentication.   You can use a filer local account if using HTTP or HTTPS for filer authentication, CIFS not necessary.

Re: Snapdrive issue on Windows Host

so we are able to see all the voluems because we enabled cifs at filer level

Highlighted

Re: Snapdrive issue on Windows Host

Yes....this is a big concern for me as well.   Do a search for the SecureAccess.xml file on the NetApp support site.   This file allows you to restrict a host and/or user to specific volumes/luns.   Depending on how your IT department is organized, the SecureAccess.xml file may or may not be sufficient.

Re: Snapdrive issue on Windows Host

also how can i check whether my newly created LUN ( thorugh Snapdrive GUI ) has dual paths