Subscribe

Snapmanager for Exchange - need to restart SnapManager service whenever DAG owner node changes

My company is running the newest version of Snapmanager for Exchange to back up an Exchange 2010 DAG. 

 

I've found that consistently, if the DAG failover cluster owner node changes, backups will fail to run unless the Snapmanager service gets restarted on all of the nodes.  After restarting the service, backups run fine.

 

No errors are logged or notifications sent, the task manager scheduled task shows a status of it failed with 0xFFFFFFFF  

 

Just curious if anyone else has run in to this.

 

 

Thank You.

 

 

Re: Snapmanager for Exchange - need to restart SnapManager service whenever DAG owner node changes

Hi,

 

You might be hitting a bug, refer http://mysupport.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=502486

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Snapmanager for Exchange - need to restart SnapManager service whenever DAG owner node changes

Thanks.

 

What's interesting in this case is that in that URL to the bug report, it indicates that the job runs successfully but that is not the case for me. 

The job doesn't run properly until the snapmanager service gets restarted on all the nodes. 

 

 

Re: Snapmanager for Exchange - need to restart SnapManager service whenever DAG owner node changes

Could you please clarify "the backup does not run properly"? 

In which phase does the backup procedure fails? you can grab this information by checking the backup report

 

Are you running a DAG-level backup? if yes please note that during (SME) DAG-level backups, the communication request is being redirected from the DAG owner node to the node where active

DB resides. Under some circumstances e.g. when running a backup after the "cluster group" failed over, the reply may not come back to the original "DAG owner" node. This creates the impression that backup never ended, until a timeout occurs

 

You can try to avoid this problem by creating the following registry value on all DAG nodes, set it to 0, and restart SnapMgrService.exe on all nodes.

 

SnapManager for Exchange\Server\UseProxyCache    = 0 (DWORD)