Subscribe
Accepted Solution

Snapmirror license not avaliable error

[ Edited ]

Recently I have installed an additional cluster machine into an existing backup cluster. We now have a total of 3 clusters. Cluster A is a filer that Snapvaults to Cluster B. I have added a new machine Cluster C into the setup for backup. Cluster B will Snapmirror to Cluster C. I have purchased and installed Snapmirror/vault licenses on all 3 machines. Everything is working nicely between A and B. I have setup the intracluster relationship between B and C and the relationship status is good between the new machines.

 

When I try to create a Snapmirror relationship between B and C after a long pause in the ONTAP 9 GUI reports "Snapmirror license is not available" warning in the GUI. I have double checked in the GUI my license for Snapmirror on all machines and they are installed correctly. Does this mean I require an additional Snapmirror license for the B and C clusters?

 

*Cluster A* -- Snapvault -- *Cluster B* -- Snapmirror -- *Cluster C*

Filer                                      Backup node 1                     Backup node 2

 

 

Re: Snapmirror license not avaliable error

Hi,

 

Refer KB https://kb.netapp.com/support/s/article/how-to-migrate-snapvault-qtrees-from-a-secondary-to-a-remote-filer-that-does-not-have-a-snapmirror-license?t=1...

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Snapmirror license not avaliable error

With the help of tech support we solved this. It turned out to be an MTU issue on the IC lif. Changing it to 1500 from 9000 solved the license availability error.

 

 

Thanks

 

Re: Snapmirror license not avaliable error

Hello guys, I had the same problem and I have resolved with change mtu from 9000 to 1500.The speed network port for our storage netapp is 1000Mb.

Thanks for your help.

Bye.

Re: Snapmirror license not avaliable error

Hi

 

I have two FAS2650 in different locations replicating to FAS2520 in another third location.

One of them fails when  I try to create the protection relationship with the license error.

The unique difference between two storage is the ethernet connection.

I Explain that.

 

The replication port of one FAS is 1GB and the Destination FAS2520 is connected to a 100MB. In this case the create the protection relationship proccess works fine.

 

The replication port of second FAS is 10GB DAC type and the destination FAS2520 is the same as above. In this case the create protection relationship proccess fails with the license error.

 

Can the speed difference be the reason for the fault in this storage?
 
Thanks in advanced

Re: Snapmirror license not avaliable error

Hi Twigs,

 

I think it might be better to make a new post instead of replying to this one. In general, the port speed difference will not cause a license error.

 

I would suggest you run "system license show" on all three clusters and verify that there are snapmirror licenses installed for each node on each cluster - the system will let you install licenses for nodes not in the cluster, so if there is any mixup, the licenses may show but not be in effect.