Subscribe

Snapprotect (Commvault intellisnap) - inconsistent in Snapdrive?

Hi

I'm testing setting up SnapProtect (aka Commvault Simpana) using a filesystem backup trying to backup an iscs LUN connected with Snapdrive. I don't have any SME/SMSQL products installed, as its this 2k8 server is effectively acting as a file server with a iscsi LUN.

I have pushed out the MediaAgent, File System, and VSS Provider to the client, created a new subclient in the default backup object and selected the iscsi LUN. The snapshot process completes without error, and I can see the snapshot in Snapdrive, but it shows as inconsistent.

Surely this isn't right? I appreciate Spanprotect is using its own VSS provider, but I would have expected the snapshot to be consistent? Any ideas?

Re: Snapprotect (Commvault intellisnap) - inconsistent in Snapdrive?

Hello,

I've just seen your question, I hope it still can help.

SnapDrive and SnapProtect are two different products, they are not linked together.

SnapDrive is not required for SnapProtect to work.

So, if I understand correctly, it is SnapDrive which shows that the SnapShot is inconsistent.

I would say it is normal because it has not been created within SnapDrive, and SnapDrive doesn't know about it (it only shows the existing snapshots).

What do you think ?

Regards,

JC

Re: Snapprotect (Commvault intellisnap) - inconsistent in Snapdrive?

This is correct.  SnapDrive can be used for LUN management but not required, and as you said, SnapDrive would not recognize application consistent SnapShots created by another app.  Also all SnapShots created by SnapProtect are application consistent.  However one thing to note, if there is a application on a LUN like SQL, you will need a SQL iDA to handle the application itself.  Otherwise just the LUN will be consistent and not the SQL in it. 

Hopefully that makes sense.