Subscribe
Accepted Solution

Unable to restore database with SMSQL

[ Edited ]

I'm unable to restore databases with SMSQL. When I try to restore snapmanager service crashes with this error: (sorry OS is in spanish)

Nombre de la aplicación con errores: SnapMgrService.exe, versión: 5.2.0.996, marca de tiempo: 0x4f0d319c

Nombre del módulo con errores: MSVCR80.dll, versión: 8.0.50727.6195, marca de tiempo: 0x4dcdd833

Código de excepción: 0xc000000d

Desplazamiento de errores: 0x0000000000031d7b

Id. del proceso con errores: 0x1520

Hora de inicio de la aplicación con errores: 0x01cd81d922175ccf

Ruta de acceso de la aplicación con errores: C:\Program Files\IBM\SnapManager for SQL Server\SnapMgrService.exe

Ruta de acceso del módulo con errores: C:\Windows\WinSxS\amd64_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.6195_none_88e41e092fab0294\MSVCR80.dll

Id. del informe: aa6c264b-edcc-11e1-8952-001a64db2e30

Anybody can help me?

Thanks.

Re: Unable to restore database with SMSQL

Can you provide some details as at what stage of restore you are getting this crash ? Does it happen always or sometimes?

What is the version of SDW ,Windows and SQL Server ?Can you send the event log and SMSQL reports?

Regards,

Abhishek

Re: Unable to restore database with SMSQL

Hi, the problem are in the backup sets for only three days, The backups are verified OK. When I open the backup set in SMSQL the service go down with only the error waht appears in this post.

The OS is Windows 2008 R2.

SQL server 2008 2 in cluster.

Snapdrive ver.6.4.2.5234

SMSQL ver. 5.2.0.996

I will try with powershell.

I will post backup and verify reports.

Thanks.

Cheché.-

Re: Unable to restore database with SMSQL

Using PowerSell for SMSQL, the restore runs OK. It seems a problem with the GUI and SnapInfo folder data?

Re: Unable to restore database with SMSQL

We're getting the same error on wizard.

If we try to run "restore-backup" it says there's no backup-set for writed databases, but we see it on wizard.

We have same soft as cheche030.

The OS is Windows 2008 R2.

SQL server 2008 2 in cluster.

Snapdrive ver.6.4.2.5234

SMSQL ver. 5.2.0.996

Additionally, we run that OS on VMware 5.0, database 6 luns as RDM: System Databases, User Databases, Log Databases, TempDB, SnapInfo and verify.

If I run "get-backup" it only shows System Databases (master, model, msdb) but inside backup-sets there are user databases (checked on other instance)

Re: Unable to restore database with SMSQL

Can you also share the logs,error id with me ?

Re: Unable to restore database with SMSQL

Via Wizard (with FUNE2K8 Instance):

Via PS (with SHP2K8 Instance):

PS C:\Program Files\IBM\SnapManager for SQL Server> restore-backup -Server "SRVV
SQL03\shp2k8" -ServerInstance "shp2k8" -Database "SharePoint_AdminContent_8600dc
bf-50ee-4e29-b137-0389e72e4cb8","SharePoint_Config","WSS_Content_8888","WSS_Cont
ent_20001","WSS_Content_20001_AF","WSS_Content_20001_DC","WSS_Content_20001_JURI
DICO","WSS_Content_20001_MKT","WSS_Content_20001_RRHH","WSS_Content_20003","WSS_
Content_20004","WSS_Content_20005","WSS_Content_20005_AdmAmbu","WSS_Content_2000
5_AdmFune","WSS_Content_20005_AdmSeguros","WSS_Content_20006","WSS_Content_30006
","WSS_Content_Everis","WSS_Content_GestProyectos","WSS_Content_Informatica","WS
S_Content_JCRosell","WSS_Content_Meridiano","WSS_Content_PMOC_50000","WSS_Conten
t_PMON","WSS_Content_PMOS_50002","WSS_Search_SRVSHP01_2","WSS_Search_SRVSHP01_3"
-SnapInfoDirectory "H:\PM_SNAPINFO\SMSQL_SnapInfo" -BackupServer "shpsql2008v\s
hp2k8" -TargetServerInstance "SRVVSQL03\shp2k8" -RestoreLastBackup 0
Initializing [restore-backup]
Connecting to server: [SRVVSQL03\shp2k8]
Connecting to server: [SRVVSQL03\shp2k8][successful]
Setup verification server value: [processing]
Retrieving backup list from SnapManager server. Please wait...
ADVERTENCIA:
There are no backups sets available with the specified information. Verify the
Server, Database and backup name.
ADVERTENCIA:
Failed to find the backup for restore.
  The backup requested to be restored was the (1) most recent, but
  (0) backups that matched the database
(SharePoint_AdminContent_8600dcbf-50ee-4e29-b137-0389e72e4cb8) and SQL Server
Instance (shp2k8) specified were found.


The database 'SharePoint_AdminContent_8600dcbf-50ee-4e29-b137-0389e72e4cb8' fro
m SQL server instance 'shp2k8' was not found in the backup 'Last backup 0' to b
e restored.

restore-backup :
The database 'SharePoint_AdminContent_8600dcbf-50ee-4e29-b137-0389e72e4cb8' fro
m SQL server instance 'shp2k8' was not found in the backup 'Last backup 0' to b
e restored.
En línea: 1 Carácter: 15
+ restore-backup <<<<  -Server "SRVVSQL03\shp2k8" -ServerInstance "shp2k8" -Dat
abase "SharePoint_AdminContent_8600dcbf-50ee-4e29-b137-0389e72e4cb8","SharePoin
t_Config","WSS_Content_8888","WSS_Content_20001","WSS_Content_20001_AF","WSS_Co
ntent_20001_DC","WSS_Content_20001_JURIDICO","WSS_Content_20001_MKT","WSS_Conte
nt_20001_RRHH","WSS_Content_20003","WSS_Content_20004","WSS_Content_20005","WSS
_Content_20005_AdmAmbu","WSS_Content_20005_AdmFune","WSS_Content_20005_AdmSegur
os","WSS_Content_20006","WSS_Content_30006","WSS_Content_Everis","WSS_Content_G
estProyectos","WSS_Content_Informatica","WSS_Content_JCRosell","WSS_Content_Mer
idiano","WSS_Content_PMOC_50000","WSS_Content_PMON","WSS_Content_PMOS_50002","W
SS_Search_SRVSHP01_2","WSS_Search_SRVSHP01_3" -SnapInfoDirectory "H:\PM_SNAPINF
O\SMSQL_SnapInfo" -BackupServer "shpsql2008v\shp2k8" -TargetServerInstance "SRV
VSQL03\shp2k8" -RestoreLastBackup 0
    + CategoryInfo          : InvalidArgument: (SMSQLPSSnapIn.SMSQLPSRestore:S
   MSQLPSRestore) [restore-backup], Exception
    + FullyQualifiedErrorId : Invalid Input for database or backup parameter.,
   SMSQLPSSnapIn.SMSQLPSRestore

Thanks for your help.

Re: Unable to restore database with SMSQL

In "-ServerInstance" parameter I wrote "Server\Instance" instead "Instance" alone and it was OK. Did you try with only one database?

Re: Unable to restore database with SMSQL

A little more explanation about our case:

We have 4 Instances on 2 SQL nodes MSFC on VMware 5.0 on Principal Site. 7 Lun's are RDMS's distributed like this: System Database, User Database, Log Database, TempDB, SnapInfo, verify, Backup.

We are using SMSQL & snapmirror to send Luns (System Database, User Database, Log Database and SnapInfo) to a remote site.

Jobs on SQL generated via SMSQL works. Logs says us jobs are completed 100%, fulls & transactional logs.

On 3 Instances there are no errors when we would restore from the last tlog (last error reported on wizard Fune2k8 was license key not founded, but error persists on Instance SHP2k8)

If i run script with one database on remote site:

PS C:\Program Files\IBM\SnapManager for SQL Server> restore-backup -Server "SRVV
SQL03\shp2k8" -ServerInstance "shp2k8" -Database "WSS_Content_Everis" -SnapInfoD
irectory "H:\PM_SNAPINFO\SMSQL_SnapInfo" -BackupServer "shpsql2008v\shp2k8" -Tar
getServerInstance "SRVVSQL03\shp2k8" -RestoreLastBackup 0
Initializing [restore-backup]
Connecting to server: [SRVVSQL03\shp2k8]
Connecting to server: [SRVVSQL03\shp2k8][successful]
Setup verification server value: [processing]
Retrieving backup list from SnapManager server. Please wait...
ADVERTENCIA:
There are no backups sets available with the specified information. Verify the
Server, Database and backup name.
ADVERTENCIA:
Failed to find the backup for restore.
  The backup requested to be restored was the (1) most recent, but
  (0) backups that matched the database (WSS_Content_Everis) and SQL Server
Instance (shp2k8) specified were found.


The database 'WSS_Content_Everis' from SQL server instance 'shp2k8' was not fou
nd in the backup 'Last backup 0' to be restored.

restore-backup :
The database 'WSS_Content_Everis' from SQL server instance 'shp2k8' was not fou
nd in the backup 'Last backup 0' to be restored.
En línea: 1 Carácter: 15
+ restore-backup <<<<  -Server "SRVVSQL03\shp2k8" -ServerInstance "shp2k8" -Dat
abase "WSS_Content_Everis" -SnapInfoDirectory "H:\PM_SNAPINFO\SMSQL_SnapInfo" -
BackupServer "shpsql2008v\shp2k8" -TargetServerInstance "SRVVSQL03\shp2k8" -Res
toreLastBackup 0
    + CategoryInfo          : InvalidArgument: (SMSQLPSSnapIn.SMSQLPSRestore:S
   MSQLPSRestore) [restore-backup], Exception
    + FullyQualifiedErrorId : Invalid Input for database or backup parameter.,
   SMSQLPSSnapIn.SMSQLPSRestore

If I run get-database it only shows me System Databases:

PS C:\Program Files\IBM\SnapManager for SQL Server> get-backup -Server "SRVVSQL0
3\SHP2k8" -ServerInstance "shp2k8" -SnapInfoDirectory "H:\PM_SNAPINFO\SMSQL_Snap
Info"
Initializing [get-backup]
Connecting to server: [SRVVSQL03\SHP2k8] [processing]
Connecting to server: [SRVVSQL03\SHP2k8] [completed]


RemoteBackup              : False
LocalBackup               : True
RemoteRetention_Type      : <none>
Retention_Type            : Backup Management Group: Standard
Transaction_Logs          :
RemoteVerification_Status :
Verification_Status       : Database Verification: Succeeded

SnapManager_SnapInfo      : H:\PM_SNAPINFO\SMSQL_SnapInfo\SQL__SHP2K8\DB__maste
                            r\FG__\StreamFullBackup\08-21-2012_04.37.45
Time_Stamp                : 08-21-2012_04.37.45
Instance                  : SHP2K8
Host                      : shp2k8
Database                  : master
Backup                    : sqlsnap__shp2k8_08-21-2012_04.37.45

RemoteBackup              : False
LocalBackup               : True
RemoteRetention_Type      : <none>
Retention_Type            : Backup Management Group: Standard
Transaction_Logs          :
RemoteVerification_Status :
Verification_Status       : Database Verification: Succeeded

SnapManager_SnapInfo      : H:\PM_SNAPINFO\SMSQL_SnapInfo\SQL__SHP2K8\DB__maste
                            r\FG__\StreamFullBackup\08-29-2012_20.37.50
Time_Stamp                : 08-29-2012_20.37.50
Instance                  : SHP2K8
Host                      : shp2k8
Database                  : master
Backup                    : sqlsnap__shp2k8_08-29-2012_20.37.50

RemoteBackup              : False
LocalBackup               : True
RemoteRetention_Type      : <none>
Retention_Type            : Backup Management Group: Standard
Transaction_Logs          : 08-21-2012_04.37.45
                            08-29-2012_20.37.50

RemoteVerification_Status :
Verification_Status       : Database Verification: Succeeded

SnapManager_SnapInfo      : H:\PM_SNAPINFO\SMSQL_SnapInfo\SQL__SHP2K8\DB__model
                            \FG__\08-21-2012_04.37.45
Time_Stamp                : 08-21-2012_04.37.45
Instance                  : SHP2K8
Host                      : shp2k8
Database                  : model
Backup                    : sqlsnap__shp2k8_08-21-2012_04.37.45

RemoteBackup              : False
LocalBackup               : True
RemoteRetention_Type      : <none>
Retention_Type            : Backup Management Group: Standard
Transaction_Logs          : 08-29-2012_20.37.50

RemoteVerification_Status :
Verification_Status       : Database Verification: Succeeded

SnapManager_SnapInfo      : H:\PM_SNAPINFO\SMSQL_SnapInfo\SQL__SHP2K8\DB__model
                            \FG__\08-29-2012_20.37.50
Time_Stamp                : 08-29-2012_20.37.50
Instance                  : SHP2K8
Host                      : shp2k8
Database                  : model
Backup                    : sqlsnap__shp2k8_08-29-2012_20.37.50

RemoteBackup              : False
LocalBackup               : True
RemoteRetention_Type      : <none>
Retention_Type            : Backup Management Group: Standard
Transaction_Logs          :
RemoteVerification_Status :
Verification_Status       : Database Verification: Succeeded

SnapManager_SnapInfo      : H:\PM_SNAPINFO\SMSQL_SnapInfo\SQL__SHP2K8\DB__msdb\
                            FG__\08-21-2012_04.37.45
Time_Stamp                : 08-21-2012_04.37.45
Instance                  : SHP2K8
Host                      : shp2k8
Database                  : msdb
Backup                    : sqlsnap__shp2k8_08-21-2012_04.37.45

RemoteBackup              : False
LocalBackup               : True
RemoteRetention_Type      : <none>
Retention_Type            : Backup Management Group: Standard
Transaction_Logs          :
RemoteVerification_Status :
Verification_Status       : Database Verification: Succeeded

SnapManager_SnapInfo      : H:\PM_SNAPINFO\SMSQL_SnapInfo\SQL__SHP2K8\DB__msdb\
                            FG__\08-29-2012_20.37.50
Time_Stamp                : 08-29-2012_20.37.50
Instance                  : SHP2K8
Host                      : shp2k8
Database                  : msdb
Backup                    : sqlsnap__shp2k8_08-29-2012_20.37.50

Number of Backups = 6.

That's a bit strange because if a run same script on other Instances it only shows me System Databases, but the wizard restore works well.

Thanks for your help!

Re: Unable to restore database with SMSQL

I've uninstalled .net framework 3.5.1 and then install it again: the problem persists. I've installed several VisualC++ runtime libraries: the problem persists.

More data&colon; Two node SQL 2008 R2 clúster. All instances on all nodes are affected by error.

The backup and verify reports are all ok.