Subscribe
Highlighted
Accepted Solution

VSC 6.2.1 restore/mount backup failed with NFS datastores

[ Edited ]

Hello,

 

I have a problem with the restore operations with VSC 6.2.1 in an ESXi 6.0 environment. I have the problem in two datacenters, both have the same storage configuration (FAS8060 HA pair with ONTAP 9.0P1). Before I was using SnapCenter 2.0 to connect to VSC but when a restore failed and I didn't get snapmirror labels with the snapshots, I removed the connection/integration. In the other environment I didn't added the VSC to SnapCenter, there was no history.

 

At this moment I make backups with VSC and that works fine, the snapshots contain a snapmirror-label which I can use for SnapVault to seconday cluster. If I want to mount a backup I receive the following error in vCenter:

Error mounting 17*.*.*20.:/vmwareds1_mount_d1eba1de944e4f8bb309409ac94db819 as datastore dfe0a495-dddb-4006-aad2-0e269fcd545c to gw-esxi-03.customer.loc. You may have reached the maximum number of NFS volumes configured in the vCenter. Check the vSphere Client for any error messages.

 

In the event on the ESX host I receive this error at the same time:

NFS mount 17*.*.*20.:/vmwareds1_mount_d1eba1de944e4f8bb309409ac94db819 failed: The mount request was denied by the NFS server. Check that the export exists and that the client is permitted to mount it.

 

The last message is strange because this ESX host has mounten the original datastore and is in the export policy. 

It it possible that it will use a different network? I only have a LIF for NFS VLAN (data) and a LIF for management of the SVM.

The SVM with the datastores is added automatically when I added the cluster via the cluster management LIF.

 

I have searched on the Web and community but didn't find a right resolution.

 

My questions:

  1. Does anybody know how to sole this, so I can restore or mount a backup?
  2. When I use SnapCenter, can I still restore backups and VM's the way I can with VSC?
  3. If I use SnapCenter, how can I have the snapmirror-label with the snapshots because this was missing.

I hope someone can help me Smiley Happy

 

Regards,

Marco

Re: VSC 6.2.1 restore/mount backup failed with NFS datastores

Hi,

 

please refer https://library.netapp.com/ecmdocs/ECMLP2561116/html/GUID-CC5DD421-3E5F-4D37-9A4D-F81B24625D3B.html

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: VSC 6.2.1 restore/mount backup failed with NFS datastores

Hello Sahana,

 

Thanks for your reply. I have done the steps from that link you posted. I find it when I was troubleshooting but I don't think it is the problem. All hosts have already best practice settings from VSC including max NFS mounts of 256 as I can remember. I do not have that much connections to the storage so I think it is something else...

 

Thanks anyway for helping!

 

Regards,

Marco

Re: VSC 6.2.1 restore/mount backup failed with NFS datastores

I have contacted NetApp support and got the right answer. There was a network issue between both clusters. That was solved and we followed the next steps:

 

Resolution:  Recommended to:

 

1.- Integrate VSC with SnapCenter which add that functionality.
2.- Add the SVMs to SC and be sure that the SVM names resolve the vserver mgmt ip address

3.- For the SV relationships to work correctly, destination cluster must be added to VSC and the destination SVM must be added to SC

 

Cause:   Some VSC features need SnapCenter integration to work properly.

 

After this I got the snapmirror-label with the snapshots and the snapvault replications are working. No errors anymore and mount datastore from backup is working.

 

Marco