Subscribe
Accepted Solution

after snap creator upgrade from 4.1P2 to 4.3.0, unable to start backup

Hi,

I upgraded from Snap creator 4.1P2 to 4.3.0.  After upgrade When I run a backup of a test configuration, I get below error:

2016-04-24 18:36:03,640 [qtp3363540-44] com.netapp.snapcreator.ui.service.SnapCreatorGUILogger ERROR - ENG-00001: Starting workflow [backup] failed with error:[Task doesn't exist:cgsnapshot]

 

From the SC GUI, schedules tab, when I edit any of existing schedules, I see that "action" dropdown is empty, I am not able to choose "backup" from dropdown.  What I am missing?

Thanks in advance.

Regards.

Re: after snap creator upgrade from 4.1P2 to 4.3.0, unable to start backup

I am not able to create a schedule manually, I get this error in gui.log.

 

2016-04-24 18:50:54,009 [qtp3363540-41] com.netapp.snapcreator.ui.service.SnapCreatorGUILogger ERROR - Couldn't create schedule in quartz
2016-04-24 18:50:54,009 [qtp3363540-41] com.netapp.snapcreator.ui.service.SnapCreatorGUILogger ERROR - Couldn't create schedule in quartz
2016-04-24 18:50:54,009 [qtp3363540-41] com.netapp.snapcreator.ui.service.SnapCreatorGUILogger ERROR - ENG-00048: Validating job
2016-04-24 18:50:54,009 [qtp3363540-41] com.netapp.snapcreator.ui.service.SnapCreatorGUILogger ERROR - ENG-00048: Validating job
2016-04-24 18:50:54,009 [qtp3363540-41] com.netapp.snapcreator.ui.service.SnapCreatorGUILogger ERROR - Creating job schedule
2016-04-24 18:50:54,009 [qtp3363540-41] com.netapp.snapcreator.ui.service.SnapCreatorGUILogger ERROR - Creating job schedule
2016-04-24 18:50:54,009 [qtp3363540-41] com.netapp.snapcreator.ui.service.SnapCreatorGUILogger ERROR - Create job schedule failed
2016-04-24 18:50:54,009 [qtp3363540-41] com.netapp.snapcreator.ui.service.SnapCreatorGUILogger ERROR - Create job schedule failed

 

Your help is much appreciated.  Thanks.

Re: after snap creator upgrade from 4.1P2 to 4.3.0, unable to start backup

Hi,

Upgrade guide for UNIX missed the step to copy license file (<snapcreatorinstallation_directory>/LICENSE) from backup to new installation location.  So after the upgrade step, when I was starting snap

creator server (<snapcreatorinstallation_directory>/bin/scServer start), it was giving this error: "Please run ./snapcreator --setup first."  I copied LICENSE file and this fixed the issue.

 

Later I encountered this error when running test backup:

 

[2016-04-24 20:38:07,088] ERROR: STORAGE-03033: Getting system version details of [vpsafiler01] failed with error [javax.net.ssl.SSLException: Connection has been shutdown: javax.net.ssl.SSLHandshakeException: Server chose SSLv3, but that protocol version is not enabled or not supported by the client.]

 

I fixed it by disabling sslv2 and sslv3 and enabling tls on storage.  I followed KB Doc ID 2022799 for this.

 

Thanks.