Subscribe
Accepted Solution

failed to configure HANA Ressource within SnapCenter 4.0

Hi, it's me and my SnapCenter miracle again...

I did not succeed to add a single container HANA db to my snapcenter ressources.

I succeed to add storage host and provide hana pluging and I've also done all the policy and scheduling stuff but as soon as I start my initial (scheduled) hana backup, it screws up and 

my backup task is hanging at the monitor-view.

 

Is there a really detailed manual describing how to add a hana db as a ressource towards the snapcenter?

 

Here the details from the HANA Host:

 

testhost04:/opt/NetApp/snapcenter/scc/logs # su - qc5adm
qc5adm@testhost04:/usr/sap/QC5/HDB81> hdbuserstore list
DATA FILE : /usr/sap/QC5/home/.hdb/testhost04/SSFS_HDB.DAT
KEY FILE : /usr/sap/QC5/home/.hdb/testhost04/SSFS_HDB.KEY

KEY BACKUP
ENV : testhost04:38115
USER: XXX_Backup
qc5adm@testhost04:/usr/sap/QC5/HDB81>

 

..And what I've added to the ressource-configuration:

 

At the ressource Details I chose single container

HANA System Name=test_testhost04

SID=QC5

HDBSQL Client Host=testhost04

HDB Secure User Store Key=BACKUP

HDBSQL OS User=qc5adm

 

 

Re: failed to configure HANA Ressource within SnapCenter 4.0

Your resource configuration looks good.

 

Are there any log informations, that you can provide from the failed backup run?

Re: failed to configure HANA Ressource within SnapCenter 4.0

Hi Nils,

I sent You two pn's.

Re: failed to configure HANA Ressource within SnapCenter 4.0

Could please also provide the SnapManagerWeb* logs, Linux host logs, JobMonitor Screen shots.

 

/opt/NetApp/snapcenter/scc/logs

C:\Program Files\NetApp\SnapCenter WebApp\App_Data\log>

 

Alternatively you could also click the "download logs" button in the monitor screen for the failed backup job.

 

Regards,

Nils

Re: failed to configure HANA Ressource within SnapCenter 4.0

After I've done some futher network analysis, I hardly realized that the required firewall ports between SC-Host and HANA-DB Host
had not been opened in both ways, even thought the Firewall admin promised and "verified" that before.
As soon as this had been done, the ressource could have been added exactly as described at the docs. 

 

...Next time I'll check the network conditions more detailed.