Subscribe

move Search Service Applications

[ Edited ]

Hello All,

I've got multiple SnapManager for SharePoint installation (mostly with SharePoint 2010) where I've got problems with the Search Service Applications indexes. I tried to move them to a LUN. 2 out of 3 (crawl and query), with the help Central Administration of SharePoint itself. However, I've got problems with moving the Admin to the correct LUN. The index migrater of SMSP only shows the last 2 indexes but not the Admin index.

I also tried to move it with the following command: stsadm -o spsearch -indexlocation i:\.

The stsadm says that the index is moved, but SMSP still says that that the index is on the C: drive. Am I moving the wrong index or is there maybe another way to move the index?

Thank you for your help.

Regards,

Eelco

Re: move Search Service Applications

Do you also have an invalid Search instance(red x)?

If so, you should be able to use the SMSP Index Migration Wizard on your app server to move it to a LUN.  I literally did this just yesterday for 2 farms in our environment.

The only downfall is that you can't change the location specifically that it moves it to.  As you can see by the screenshot, it is in the program files default layout, just on the D drive.

Re: move Search Service Applications

Hello Andrew,

I'm familiar with the tool, however I've got a lot of problems with this tool. I've setup a test environment, but the migrator didn't see any index (I've got this problem more in other environments).

Regards,

Eelco