Subscribe

problem syncing to smo repository

[ Edited ]

Hi,

I have an issue where 5 out of 6 installations of smo client runs smoothly. The problem is the last one where i get this error:

[oracle@xxxxxx ~]$  smo profile sync -repository -dbname xxx -host xxx.xxx.xxx.xxx -port 1521 -login -username xxx

ERROR] SMO-20017: User "oracle" has credentials for repository "xxx@xxx/xxx.xxx.xxx.xxx:1521" but validity could not be checked.  Error: SMO-09032: Failed  to connect to repository: Io exception: Connection reset: [ORA-17002].
[ERROR] SMO-01104: Error invoking command: SMO-20017: User "oracle" has credentials for repository "xxx@xxx/xxx.xxx.xxx.xxx:1521" but validity could not be checked.  Error: SMO-09032: Failed  to connect to repository: Io exception: Connection reset: [ORA-17002].

There are no firewalls between hosts (they are on the same network). Port 1521 is reachable and i can login with the smo repository user via sqlnet.

But at this point i don't know how to troubleshoot this further, and wouldn't mind some assistance.

The version of smo is 3.0.1

Servers are RHEL5 Kernel: 2.6.18-194.el5

Thanks in advance

//Morgan

Re: problem syncing to smo repository

It is always best to go to the specific log files rather than the console output.  More times than not there is more detail in those logs that what you scraped from the screen.  Plus you can look forward and backward in the file to see the stuff has has already happened.

That means running snapdrive.dc and then running smo operation dumo and looking at specific sd-trace.logs and smo_of*.log files.

As another quick check, can you create a new profile for this same database and does that work properly?