Subscribe

snapcreator3.5.0 tries to delete "clone"-snapshot and thus yields an error

[ Edited ]

Hello,

I'm using snapcreator 3.5.0 at a customer with db2 installed on AIX. The customer has 3 NetApp-Filers onsite, two "primary" as a cluster and one "secondary" as nearstore. Snapcreator is used to backup the database and transfer the snapshots via snapvault to the secondary. Some weeks ago we used flexclone on the secondary to get a clone of his productive database - until there everything went fine. For a few days now snapcreator is complaining that every backup-job runs into an error. We found this in the logs:

########## Running NetApp Snapshot Delete on Secondary san3 ##########

[Fri Feb 17 10:52:13 2012] WARN: More than 80 NetApp Snapvault snapshots exist, older snapshots of san3:SV_SAPWAP_temp will be automatically deleted!

[Fri Feb 17 10:52:13 2012] WARN: Deleting NetApp Snapvault Snapshot wap_snap-SV_daily_20120116124100 on san3:SV_SAPWAP_temp

[Fri Feb 17 10:52:13 2012] INFO: NetApp Snapshot Delete of wap_snap-SV_daily_20120116124100 on san3:SV_SAPWAP_temp completed Successfully

[Fri Feb 17 10:52:13 2012] WARN: More than 80 NetApp Snapvault snapshots exist, older snapshots of san3:SV_SAPWAP_temp will be automatically deleted!

[Fri Feb 17 10:52:13 2012] WARN: Deleting NetApp Snapvault Snapshot wap_snap-SV_daily_20111201200100 on san3:SV_SAPWAP_temp

[Fri Feb 17 10:52:14 2012] ZAPI: volume clone

[Fri Feb 17 10:52:14 2012] ERROR: [scf-00013] NetApp Snapshot Delete of wap_snap-SV_daily_20111201200100 on san3:SV_SAPWAP_temp failed! Exiting

The snapshot mentioned is busy because it's just the one we are still using as a clone - thus it's pretty much OK that it cannot be deleted. Is there a way to skip this "error"? The main problem at the moment is that every job is marked "red" in the snapcreator gui and the customer cannot tell if the backups worked or not.

Best regards

Martin Glora

Re: snapcreator3.5.0 tries to delete "clone"-snapshot and thus yields an error

I am afraid this behavior is working by design. According to your snapshot policy we are supposed to delete snapshot and we cant because it is busy because you have a clone.

We can certainly look at making this error a warning instead of an error so it shows up yellow, we will have to discuss this further.

As for a solution, if you are going to create a clone and leave it for a while then rename the snapshot to something else. This way SC wont even look at the snapshot and you wont get an error. Your other option is to delete the clone which is causing the problem in the first place since the snapshot is locked.

Hope this helps

Regards,

Keith

Re: snapcreator3.5.0 tries to delete "clone"-snapshot and thus yields an error

Hello Keith,

thanks for your fast answer - I'll check with the customer, but renaming the snapshots should be OK for us.

Best regards

Martin Glora

Re: snapcreator3.5.0 tries to delete "clone"-snapshot and thus yields an error

Hello Keith,

after renaming the "clone"-snapshots everything works fine! Thanks once more

Best regards

Martin Glora

Re: snapcreator3.5.0 tries to delete "clone"-snapshot and thus yields an error

Great thanks for getting back to us and glad it worked!

Keith