Subscribe
Accepted Solution

snapmanager for sql service not getting started

After installling snapmanager for sql on windows 2003 ent sp2 32bit server,snapamager service not getting started automatically.

its giving below error in event viewer

Event ID: 7009

Task Category: None

Level: Error

Keywords: Classic

User: N/A
Computer:
server1.mydomain.com

Description:
A timeout was reached (30000 milliseconds) while waiting for the SnapManager Service service to connect

Event ID: 7000

Task Category: None

Level: Error

Keywords: Classic

User: N/A
Computer:
server1.mydomain.com

Description:
The SnapManager Service service failed to start due to the following error:

The service did not respond to the start or control request in a timely fashion.

snapmanager for sql service not getting started

hi everybody,

i have recognise this issue and rectified it also,please find below some information where i have changed in the server registry key.

  • When a service starts, the service communicates to the Service Control Manager how long the service must have to start (the time-out period for the service). If the Service Control Manager does not receive a "service started" notice from the service within this time-out period, the Service Control Manager terminates the process that hosts the service. This time-out period is typically less than 30 seconds. If you do not adjust this time-out period, the Service Control Manager ends the process and the attached debugger while you are trying to debug. To adjust this time-out period, follow these steps:
    1. In Registry Editor, locate, and then right-click the following registry subkey:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control

    2. Point to New, and then click DWORD Value. In the right pane of Registry Editor, notice that New Value #1 (the name of a new registry entry) is selected for editing.
    3. Type ServicesPipeTimeout to replace New Value #1, and then press ENTER.
    4. Right-click the ServicesPipeTimeout registry entry that you created in step c, and then click Modify. The Edit DWORD Value dialog box appears.
    5. In the Value data text box, type TimeoutPeriod, and then click OK

      Note TimeoutPeriod is a placeholder for the value of the time-out period (in milliseconds) that you want to set for the service. For example, if you want to set the time-out period to 24 hours (86400000 milliseconds), type 86400000.
    6. Restart the computer. You must restart the computer for Service Control Manager to apply this change.

please find the link below of KB artcial of microsoft for more details.

http://support.microsoft.com/kb/824344