Subscribe
Accepted Solution

snapmirror update fails from snapcreator but not filer

[ Edited ]

I am trying to initiate a snapmirror update from snapcreator.  When I do, I get the following message in the logs:

No Snapmirror Relationship for ASHNAS0002:ashpce22_data_01 exist! Exiting

If I do a manual snapmirror update on the filer, I am able to sync up the data.

**********************************************************

Versions:

snapcreator 3.3.0

ONTAP: 7.3.3

**********************************************************

In the snapcreator configuration:

VOLUMES=ASHNAS0002:ashpce22_data_01

...

NTAP_SNAPMIRROR_UPDATE=Y
NTAP_SNAPMIRROR_CASCADING_UPDATE=N
SNAPMIRROR_VOLUMES=ASHNAS0002:ashpce22_data_01
SNAPMIRROR_CASCADING_VOLUMES=
NTAP_SNAPMIRROR_WAIT=10
NTAP_SNAPMIRROR_USE_SNAPSHOT=N
NTAP_SNAPMIRROR_MAX_TRANSFER=

**********************************************************

on the filer:

ASHNAS0002> snapmirror status ashpce22_data_01
Snapmirror is on.
Source                       Destination                     State          Lag        Status
ASHNAS0002:ashpce22_data_01  ASHNAS0002:ashpce22_data_02_sm  Snapmirrored   00:20:29   Idle

I have ensured all of the names are short names and are the same throughout the whole snapcreator configuration.  What am I missing?

Re: snapmirror update fails from snapcreator but not filer

Hey derek-

I just sent an email to stacy... If I¹m reading the log correctly ­ you have

the snapmirror relationship on the same netapp controller. SnapCreator

doesn¹t support the snapmirror relationship being on the same netapp

controller. The snapmirror relationship would need to span two distinct

controllers for SnapCreator..

Greg Loughmiller

Global Enterprise Applications Solution Lead, NCIE-SAN

Enterprise Applications Solution Team

NetApp

678.982.6099 Mobile Phone

lgreg@netapp.com

From: derekdoucette <xdl-communities@netapp.com>

Reply-To: "netapp-dev@sgaur.hosted.jivesoftware.com"

<netapp-dev@sgaur.hosted.jivesoftware.com>

Date: Mon, 11 Apr 2011 10:45:37 -0700

To: gregory loughmiller <lgreg@netapp.com>

Subject: "snapmirror update fails from snapcreator but not filer" [NetApp

Community > Products & Solutions > Databases & Enterprise Apps >

SnapCreator]

<http://communities.netapp.com/index.jspa>

snapmirror update fails from snapcreator but not filer

created by derekdoucette

<http://communities.netapp.com/people/derekdoucette> in SnapCreator - View

the full discussion <http://communities.netapp.com/message/51941#51941>

I am trying to initiate a snapmirror update from snapcreator.  When I do, I

get the following message in the logs: No Snapmirror Relationship for

ASHNAS0002:ashpce22_data_01 exist! Exiting  If I do a manual snapmirror

update on the filer, I am able to sync up the

data. **********************************************************Versions:sna

pcreator 3.3.0ONTAP:

7.3.3 **********************************************************In the

snapcreator

configuration: VOLUMES=ASHNAS0002:ashpce22_data_01...NTAP_SNAPMIRROR_UPDATE=

YNTAP_SNAPMIRROR_CASCADING_UPDATE=NSNAPMIRROR_VOLUMES=ASHNAS0002:ashpce22_da

ta_01SNAPMIRROR_CASCADING_VOLUMES=NTAP_SNAPMIRROR_WAIT=10NTAP_SNAPMIRROR_USE

SNAPSHOT=NNTAPSNAPMIRROR_MAX_TRANSFER=************************************

********************** on the filer:ASHNAS0002> snapmirror status

ashpce22_data_01Snapmirror is on.Source                      

Destination                     State          Lag       

StatusASHNAS0002:ashpce22_data_01  ASHNAS0002:ashpce22_data_02_sm 

Snapmirrored   00:20:29   Idle  I have ensured all of the names are short

names and are the same throughout the whole snapcreator configuration.  What

am I missing?

Reply to this message by replying to this email -or- go to the message on

NetApp Community <http://communities.netapp.com/message/51941#51941> Start a

new discussion in SnapCreator at NetApp Community

<http://communities.netapp.com/choose-container!input.jspa?contentType=1&con

tainerType=14&container=2481