Subscribe

wrong NTAP_METADATA_SNAPSHOT_CREATE_CMDx behaviour

[ Edited ]

Dear SnapCreator users,

 

I am currently testing the use of the NTAP_METADATA_SNAPSHOT_CREATE_CMDx parameter to backup an Oracle database on RHEL 6.6 with SC 4.1.1

The database is stored on 2 separate LVM disk groups:

 

datavg contains 1 lun stored in a dedicated Ontap volume and stores all datafiles, control files, and online redo logs

archvg contains 1 lun stored in a dedicated Ontap volume and stores archived log files

 

here are the lines in my config file for those 2 volumes:

 

VOLUMES=svm-iscsi-oracle1:v_iscsi_data1,v_iscsi_archlog1

META_DATA_VOLUME=svm-iscsi-oracle1:v_iscsi_archlog1

 

Because LVM is in use, I configure my snapcreator job to call snapdrive on the Oracle server using the SC agent:

 

NTAP_SNAPSHOT_CREATE_CMD01="/usr/sbin/snapdrive" snap create -dg datavg -snapname %SNAME-%SNAP_TYPE_%SNAP_TIME

NTAP_METADATA_SNAPSHOT_CREATE_CMD01="/usr/sbin/snapdrive" snap create -dg archvg -snapname %SNAME-%SNAP_TYPE_%SNAP_TIME

 

My job fails because SC server calls first NTAP_METADATA_SNAPSHOT_CREATE_CMD01 to create the snapshot using snapdrive, then 

attempts to create a second snapshot with the same name on my META_DATA_VOLUME, directly (not via the agent).

 

The log is clear about this:

 

########## Application Unquiesce finished successfully ##########

##########File system plug-in not defined. Skipping file system quiesce ##########

 

--> call to the agent to execute the snapdrive:

 

 

##########Metadata Snapshot Create Commands Started##########

[2015-01-21 18:38:20,638] INFO: [rhel1:9090 (4.1.1.1)] Executing Snapshot copy create command ["/usr/sbin/snapdrive" snap create -dg archvg -snapname snapcreator_made-hourly_20150121183738] on rhel1

[2015-01-21 18:38:20,638] TRACE: Command ["/usr/sbin/snapdrive" snap create -dg archvg -snapname snapcreator_made-hourly_20150121183738] finished with exit code: [0] stdout: [snap create -dg archvg -snapname snapcreator_made-hourly_20150121183738] stderr: []

[2015-01-21 18:38:20,638] DEBUG: [rhel1:9090 (4.1.1.1)] Command ["/usr/sbin/snapdrive" snap create -dg archvg -snapname snapcreator_made-hourly_20150121183738] finished successfully with message [snap create -dg archvg -snapname snapcreator_made-hourly_20150121183738]

[2015-01-21 18:38:20,638] INFO: Snapshot copy create completed successfully

########## Metadata Snapshot copy create commands finished successfully ##########

 

--> then local execution of a snapshot with the same name directly by SC server:

 

########## Skipping other Snapshot tasks as Metadata Snapshot commands executed ##########

########## Creating meta data Snapshot copy for svm-iscsi-oracle1:v_iscsi_archlog1 ##########

[2015-01-21 18:38:20,641] INFO: Creating Snapshot copy for svm-iscsi-oracle1:v_iscsi_archlog1on svm-iscsi-oracle1

[2015-01-21 18:38:20,807] INFO: STORAGE-02007: Creating Snapshot copy [snapcreator_made-hourly_20150121183738] on volume [v_iscsi_archlog1]

[2015-01-21 18:38:20,807] DEBUG: snapcreator_made-hourly_20150121183738 v_iscsi_archlog1

 

--> results in failure because a snapshot with same name already exists on v_iscsi_archlog1

 

Can someone please help me here? 

 

Thanks a lot in advance

 

Pierre

 

 

 

Re: wrong NTAP_METADATA_SNAPSHOT_CREATE_CMDx behaviour

Pierre,

 

I'm afraid that you've hit a bug.

 

The goos news is that it has already been fixed in Snap Creator 4.1.1P2.

The link is here:  http://mysupport.netapp.com/NOW/download/software/snapcreator_framework/4.1.1P2/

 

You should be able to just update the Snap Creator Server to this patched version, but there is a change you may need to update the agent as well.

 

Hope this helps,

 

John

Re: wrong NTAP_METADATA_SNAPSHOT_CREATE_CMDx behaviour

Thanks John, pretty obvious burt description indeed.

 

I will update and let you know.

 

(Don't know how I missed that patch by the way)

 

Kind regards

 

Pierre

 

Re: wrong NTAP_METADATA_SNAPSHOT_CREATE_CMDx behaviour

[ Edited ]

Hi,

 

is the bug fixed in the right way? I'm still using 4.1.1P2 (due to another issue I had in upgrading to 4.1.1P4), but here the METADATA command should work correctly...

 

However, what I see now is that only the 'normal' snapshot on the metadata volume is taken on Storage level, but the command is no longer executed.

 

VOLUMES=LOCSD9101CLI:locli4_oralog_applname_locva4019cli,locli4_oradata_applname_locva4019eam
META_DATA_VOLUME=LOCSD9101CLI:locli4_oralog_applname_locva4019cli

 

NTAP_SNAPSHOT_CREATE_CMD01="C:\Program Files\NetApp\SnapDrive\sdcli.exe" snap create -s %SNAME-%SNAP_TYPE_%SNAP_TIME -D H -x -u no
NTAP_METADATA_SNAPSHOT_CREATE_CMD="C:\Program Files\NetApp\SnapDrive\sdcli.exe" snap create -s %SNAME-%SNAP_TYPE_%SNAP_TIME -D F G I -x -u no

 

Results in the following:

 

########## SNAPSHOT CREATE COMMANDS ##########
[2015-06-08 19:02:59,890] INFO: [192.168.12.119:9090 (4.1.1.1)] Executing Snapshot create  command ["C:\Program Files\NetApp\SnapDrive\sdcli.exe" snap create -s orasnap_locva4019cli-snap8h_20150608190133 -D H -x -u no] on 192.168.12.119
[2015-06-08 19:02:59,890] INFO: Snapshot create  completed successfully
########## Snapshot copy create commands finished successfully ##########
[2015-06-08 19:02:59,894] INFO: Skipping snapshot creation using ZAPI.
########## File system plug-in not defined. Skipping file system unquiesce ##########

....

....

########## Application Unquiesce finished successfully ##########
########## File system plug-in not defined. Skipping file system quiesce ##########
########## Metadata Snapshot Create Commands Started  ##########
########## Creating meta data Snapshot copy for LOCSD9101CLI:locli4_oralog_applname_locva4019cli ##########
[2015-06-08 19:03:10,371] INFO: Creating Snapshot copy for LOCSD9101CLI:locli4_oralog_applname_locva4019clion LOCSD9101CLI
[2015-06-08 19:03:12,950] INFO: STORAGE-02007: Creating Snapshot copy [orasnap_locva4019cli-snap8h_20150608190133] on volume [locli4_oralog_applname_locva4019eam]
[2015-06-08 19:03:12,950] INFO: STORAGE-02008: Snapshot copy [orasnap_locva4019cli-snap8h_20150608190133] on volume [

 

The Metadata CMD is not even being called, or am I missing something here?

 

 

Re: wrong NTAP_METADATA_SNAPSHOT_CREATE_CMDx behaviour

Marcel,

 

Apparently there is a bug on this.  It will be fixed in the next release (4.1.2).

 

In the meantime, you should be able to make a simplae change to get this working.

 

Change:

NTAP_METADATA_SNAPSHOT_CREATE_CMD="C:\Program Files\NetApp\SnapDrive\sdcli.exe" snap create -s %SNAME-%SNAP_TYPE_%SNAP_TIME -D F G I -x -u no

 

To:

NTAP_METADATA_SNAPSHOT_CREATE_CMD01="C:\Program Files\NetApp\SnapDrive\sdcli.exe" snap create -s %SNAME-%SNAP_TYPE_%SNAP_TIME -D F G I -x -u no

 

Basically you are just adding "01" to the end of  NTAP_METADATA_SNAPSHOT_CREATE_CMD

 

Hope this helps!

 

John

Re: wrong NTAP_METADATA_SNAPSHOT_CREATE_CMDx behaviour

Well, that works, thanks a lot.

 

Seems in general to me that config options are a bit inconsistent, some have 01,02...99, some don't. For example, in an older thread (during SC 3.5 times), Keith stated that you can define multiple ARCHIVE_LOG_DIR with ARCHIVE_LOG_DIR01, ARCHIVE_LOG_DIR02, etc... This however doesn't work with 4.1

 

So for some, you need a number, for some you can't have one...