Subscribe

7MTT running on Linux error - Report Generation Failed

Hello, I am trying to generate an assessment for a few filers running 7-Mode using the 7MTT that is running on linux. Every time I try to generate a report, I get the "Report Generation Failed" error after a few second. Any help would be appreciated! Here are the logs:

 

2015-03-25 15:11:01.793 MDT [c.n.t.g.s.SystemDetailsServiceImpl: INFO] [transition-server-thread6]: startInventoryCollectReportOperation() : starting inventory collect operation for version '8.2.3'
2015-03-25 15:11:01.793 MDT [c.n.transition.gui.util.ProjectUtil: DEBUG] [transition-server-thread6]: validateSessionTimeOut : Validates session time out
2015-03-25 15:11:01.795 MDT [c.n.t.g.s.SystemDetailsServiceImpl: INFO] [transition-server-thread6]: startInventoryCollectReportOperation() : started inventory collect operation
2015-03-25 15:11:16.805 MDT [c.n.t.g.s.SystemDetailsServiceImpl: INFO] [transition-server-thread6]: getInventoryCollectReportURL() : collect inventory collect report
2015-03-25 15:11:16.806 MDT [c.n.transition.gui.util.ProjectUtil: DEBUG] [transition-server-thread6]: validateSessionTimeOut : Validates session time out
2015-03-25 15:11:16.806 MDT [c.n.t.g.s.SystemDetailsServiceImpl: INFO] [transition-server-thread6]: getInventoryCollectReportURL() : collecting inventory collect report for process id '77'
2015-03-25 15:11:16.809 MDT [c.n.t.g.s.TransitionGUIExceptionHandler: ERROR] [transition-server-thread6]: Exception:
java.lang.Exception: Report generation failed.
at com.netapp.transition.multicontrollerprecheck.MulticontrollerPrecheckRunner.getReportLinks(MulticontrollerPrecheckRunner.java:100) ~[transition-multicontroller-precheck.jar:2.0]
at com.netapp.transition.multicontrollerprecheck.AptOrchestrationLayer.getReport(AptOrchestrationLayer.java:309) ~[transition-multicontroller-precheck.jar:2.0]
at com.netapp.transition.gui.service.SystemDetailsServiceImpl.getInventoryCollectReportURL(SystemDetailsServiceImpl.java:320) ~[transition-gui.jar:2.0]
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.7.0_75]
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) ~[na:1.7.0_75]
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[na:1.7.0_75]
at java.lang.reflect.Method.invoke(Method.java:606) ~[na:1.7.0_75]
at com.google.gwt.user.server.rpc.RPC.invokeAndEncodeResponse(RPC.java:561) [gwt-servlet.jar:na]
at com.google.gwt.user.server.rpc.RemoteServiceServlet.processCall(RemoteServiceServlet.java:208) [gwt-servlet.jar:na]
at com.google.gwt.user.server.rpc.RemoteServiceServlet.processPost(RemoteServiceServlet.java:248) [gwt-servlet.jar:na]
at com.google.gwt.user.server.rpc.AbstractRemoteServiceServlet.doPost(AbstractRemoteServiceServlet.java:62) [gwt-servlet.jar:na]
at javax.servlet.http.HttpServlet.service(HttpServlet.java:641) [tomcat-embed-core-7.0.27.jar:7.0.27]
at javax.servlet.http.HttpServlet.service(HttpServlet.java:722) [tomcat-embed-core-7.0.27.jar:7.0.27]
at com.google.inject.servlet.ServletDefinition.doService(ServletDefinition.java:263) [guice-servlet.jar:na]
at com.google.inject.servlet.ServletDefinition.service(ServletDefinition.java:178) [guice-servlet.jar:na]
at com.google.inject.servlet.ManagedServletPipeline.service(ManagedServletPipeline.java:91) [guice-servlet.jar:na]
at com.google.inject.servlet.FilterChainInvocation.doFilter(FilterChainInvocation.java:62) [guice-servlet.jar:na]
at com.google.inject.servlet.ManagedFilterPipeline.dispatch(ManagedFilterPipeline.java:118) [guice-servlet.jar:na]
at com.google.inject.servlet.GuiceFilter.doFilter(GuiceFilter.java:113) [guice-servlet.jar:na]
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243) [tomcat-embed-core-7.0.27.jar:7.0.27]
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210) [tomcat-embed-core-7.0.27.jar:7.0.27]
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:225) [tomcat-embed-core-7.0.27.jar:7.0.27]
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:169) [tomcat-embed-core-7.0.27.jar:7.0.27]
at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:472) [tomcat-embed-core-7.0.27.jar:7.0.27]
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:168) [tomcat-embed-core-7.0.27.jar:7.0.27]
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:98) [tomcat-embed-core-7.0.27.jar:7.0.27]
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118) [tomcat-embed-core-7.0.27.jar:7.0.27]
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:407) [tomcat-embed-core-7.0.27.jar:7.0.27]
at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:999) [tomcat-embed-core-7.0.27.jar:7.0.27]
at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:565) [tomcat-embed-core-7.0.27.jar:7.0.27]
at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:309) [tomcat-embed-core-7.0.27.jar:7.0.27]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [na:1.7.0_75]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [na:1.7.0_75]
at java.lang.Thread.run(Thread.java:745) [na:1.7.0_75]
2015-03-25 15:11:16.809 MDT [c.n.t.g.s.TransitionGUIExceptionHandler: ERROR] [transition-server-thread6]: Exception : java.lang.Exception: Report generation failed.

Re: 7MTT running on Linux error - Report Generation Failed

Hi Devo8604,

 

Are you on the latest 7MTT2.0 GA build?

If not i would recommend the latest 7MTT2.0 GA build and check.

 

Also if you cannot upgrade , please upload the logs of 7MTT tool

That can help us diagnose the issue more

 

-Srinivas