Subscribe

7Mode NTP Clock Skewed Settings

[ Edited ]

I am a little new to NetApp so it is likely there is an easy fix.


I have a FAS2240 with HA running 8.1.2. Which I know I need to upgrade, but recently I have started receiving clock skewed messages.  I verified the controller is pointed to the correct ntp server and that everything with that server is working correctly. I have researched and can not find an easy way to see whether things are working correctly though in logs as many things have been deprecated. The time difference is around 42 seconds, and I can not seem to get that part to update to be in time with Active Directory.

 

I looked up information and saw where it said to look up ntp-peer file in the raw autosupport data. Here is what I saw:

 

remote           local      st poll reach  delay   offset    disp
=======================================================================
*10.5.0.1        10.95.0.101      8 1024    0 0.00102  0.000301 3.99217

 

I do not fully understand what I am reading but I did find one issue. When I first started the controller was seperated into two interface groups, one which was used for cifs and one for nfs. We removed the interface groups and created one overall interface group and changed the address to the nfs address. The local address here shows the old cifs address which is no longer used and has been removed from the RC file and I can not find any information where the address is still in use. I do not know what the local ip means, or where it would be pulling that information from. 

 

Is anyone able to help me figure out what options I have, and why the 10.95 address would still be showing up?

 

Thanks for any help you can provide!

Re: 7Mode NTP Clock Skewed Settings

Restart nap by "options timed.enable off" and "options timed.enable on", then issue AutoSupport by "options autosupport.doit ntpd_restart". Check ntpdc output in autosupport. Local IP address may be changed.

Re: 7Mode NTP Clock Skewed Settings

Saw this issue with 4 filers running ONTAP 8.1.4 P8 in 7-Mode and restarting the daemon with the following commands resolved the issue

 

Run "options time" on each filer and check settings match and are using ntp for timed.proto and same ip address for timed.servers

Run "options timed.enable on" and then "options timed enable off" followed by options autosupport.doit ntpd_restart on each filer

Allow some time for synch to remediate itself

Re: 7Mode NTP Clock Skewed Settings

 

Re: 7Mode NTP Clock Skewed Settings

Correct.

Checked all the filers in synch with net time command e.g. net time \\<name of filer> for each filer

All in synch