Subscribe

Auto commit with Snaplock enterprise

Hi

I am trying to assist a customer with what should be a simple task.

auto commiting files in a snaplock enterprise volume.

all options have been set:

compliance clock initialised

compliance aggregate and volume created

snaplock options set to

default=max

min=0y

max=7y

snaplock auto commit =1m

this means that when I write files to the volume after 1 minute the read only flag should automatically be set on

this is not the case, I can delete files to my hearts content

if I manually set the attribute on the file to read only it will commit it.

why doesn't the autocommit option work as expected. is the customer expected to set every file to read only manually every time they write data to the volume?

any help much appreciated

Re: Auto commit with Snaplock enterprise

Haven't played with it, but our courseware from the NPSA class says it is based on a scan process and may take some time before the files are changed to a read only state.

It also says the min delay is two hours. ( as does the man page )

'm' is a valid time indicator - but it refers to months instead of minutes.


I hope this response has been helpful to you.

At your service,


Eugene E. Kashpureff
ekashp@kashpureff.org
Fastlane NetApp Instructor and Independent Consultant
http://www.fastlaneus.com/ http://www.linkedin.com/in/eugenekashpureff

(P.S. I appreciate points for helpful or correct answers.)

Re: Auto commit with Snaplock enterprise

I have waited for 3 hours and still it hasn't autocommited.......

would have expected better functionality than that?

Re: Auto commit with Snaplock enterprise

If you have delay set to '1m' it will take one month to commit  ?

The man page isn't specific on what additional delay the scan implements, but with a minimum

delay of two hours I wouldn't be surprised if the additional delay was hours.


I hope this response has been helpful to you.

At your service,


Eugene E. Kashpureff
ekashp@kashpureff.org
Fastlane NetApp Instructor and Independent Consultant
http://www.fastlaneus.com/ http://www.linkedin.com/in/eugenekashpureff

(P.S. I appreciate points for helpful or correct answers.)

Re: Auto commit with Snaplock enterprise

Another possibility is that setting invalid value effectively disables autocommit.

Re: Auto commit with Snaplock enterprise

'1m' would be a valid value, but it would refer to 1 month.

It should also be noted that just writing to the file ( to test ) will defeat the auto commit process.

I'm interested in how long the scanning process may add delay, and will try to set up a read test of the files attributes to measure it in the lab...


I hope this response has been helpful to you.

At your service,


Eugene E. Kashpureff
ekashp@kashpureff.org
Fastlane NetApp Instructor and Independent Consultant
http://www.fastlaneus.com/ http://www.linkedin.com/in/eugenekashpureff

(P.S. I appreciate points for helpful or correct answers.)

Re: Auto commit with Snaplock enterprise

Minimum autocommit period is 2hours, RTFM.