Subscribe
Highlighted
Accepted Solution

DFM - OnCommand - connection issue

Hello,

I've a controller that doesn't connect correctly with dfm/oncommand. Not through http, nor through https

Controller status message in dfm: Host Communication Failed

dfm host diag results.

XML (https port 443)  Error Can't connect to host (err=10061).

XML (http port 80)  Error HTTP POST - Unable to send the API request(err=10054).

It's not the firewall blocking something in between (all ports open for test). The partner in the metroclusters works perfect !

KR, Geert

Re: DFM - OnCommand - connection issue

Have you compared the output of the dfm host diag from the controller that is OK to the one that is not?  Are there any differences?

Any chance you could post the output here?

Also, have you looked at the Controller Settings in Operations Manager to verify that there aren't any differences in Login Protocol, credentials, etc?

Re: DFM - OnCommand - connection issue

Tnx for the feedback. This was all been verified.

Solution:

filer> options ssl.enable off

filer> secureadmin setup ssl

filer> options ssl.enable on

Found an additional link when trying to logon with oncommand system manager. This brought the error "com.netapp.nwf.client.communication.ResponseException".

Re: DFM - OnCommand - connection issue

[ Edited ]

Hi All,

 

In addition to the SSL configuration if you get the following error from a running a dfm host diag:

 

XML (http port 80)     Can't connect to host (err=10061).

 

Check the storage controller to see if the following options are ON.

 

options httpd.admin.ssl.enable

options httpd.admin.enable (XML http port 80)

 

https://kb.netapp.com/support/index?page=content&id=2016502&locale=en_US

 

As per the notes in the KB article:

 

Notes:

  • vFiler units are discovered through XML to the hosting storage systems. Therefore, if XML is not enabled to the hosting storage system (hostLogin is not set), the vFiler discovery and monitoring will be disabled for that storage system.

/matt

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.