Subscribe
Accepted Solution

DFM snapshot issue

Hello,

We have a strange situation on our environment. We were using DFM to triger snapshots and do SM and SV replication for our VMware environment accross multiple arrays. But two days ago we stopped it and completely reinstall DFM server BUT on primary volumes snapshots schedules (hourly, daily,..) are still generated with old configuration!! And we don't know where to stop them.

Is there a way to stop this snapshot schedule?  Or to see it on the cli?

If I check my volume options "nosnap=on" so it means there's no local schedule running.

Thanks for your help.

Renaud

Re: DFM snapshot issue

Interesting. Can you post the following here:

snap list volume.name

snap sched volume.name

vol options volume.name

where "volume.name "is a volume with this issue.

Re: DFM snapshot issue

Eric,

Here are infos:

netapparray01> snap list fc_esxtest_systems

Volume fc_esxtest_systems

working...

  %/used       %/total  date          name

----------  ----------  ------------  --------

  0% ( 0%)    0% ( 0%)  Apr 26 14:17  fc_esxtest_systems_hourly_2012-04-26_1415+0200_1

  0% ( 0%)    0% ( 0%)  Apr 26 14:15  fc_esxtest_systems_hourly_2012-04-26_1415+0200

  1% ( 0%)    0% ( 0%)  Apr 26 13:09  netapparray02(1574854763)_backup_fc_esxtest_systems_qt_esxtest_systems-src.0 (snapvault)

  1% ( 0%)    0% ( 0%)  Apr 26 12:17  fc_esxtest_systems_hourly_2012-04-26_1215+0200_1

  1% ( 0%)    0% ( 0%)  Apr 26 12:15  fc_esxtest_systems_hourly_2012-04-26_1215+0200

  1% ( 0%)    0% ( 0%)  Apr 26 12:07  fc_esxtest_systems_daily_2012-04-26_1205+0200_1

  1% ( 0%)    0% ( 0%)  Apr 26 12:05  fc_esxtest_systems_daily_2012-04-26_1205+0200

  1% ( 0%)    0% ( 0%)  Apr 26 11:23  netapparray03(1788254433)_fc_esxtest_systems.1 (snapmirror)

  1% ( 0%)    0% ( 0%)  Apr 26 10:17  fc_esxtest_systems_hourly_2012-04-26_1015+0200_1

  1% ( 0%)    0% ( 0%)  Apr 26 10:15  fc_esxtest_systems_hourly_2012-04-26_1015+0200

  2% ( 0%)    1% ( 0%)  Apr 26 08:17  fc_esxtest_systems_hourly_2012-04-26_0815+0200_1

  2% ( 0%)    1% ( 0%)  Apr 26 08:15  fc_esxtest_systems_hourly_2012-04-26_0815+0200

  2% ( 0%)    1% ( 0%)  Apr 26 07:02  fc_esxtest_systems_daily_2012-04-26_0700+0200_1

  2% ( 0%)    1% ( 0%)  Apr 26 07:00  fc_esxtest_systems_daily_2012-04-26_0700+0200

  2% ( 0%)    1% ( 0%)  Apr 26 06:16  fc_esxtest_systems_hourly_2012-04-26_0615+0200_1

  2% ( 0%)    1% ( 0%)  Apr 26 06:15  fc_esxtest_systems_hourly_2012-04-26_0615+0200

  3% ( 0%)    1% ( 0%)  Apr 26 04:16  fc_esxtest_systems_hourly_2012-04-26_0415+0200_1

  3% ( 0%)    1% ( 0%)  Apr 26 04:15  fc_esxtest_systems_hourly_2012-04-26_0415+0200

  3% ( 0%)    1% ( 0%)  Apr 26 02:16  fc_esxtest_systems_hourly_2012-04-26_0215+0200_1

  3% ( 0%)    1% ( 0%)  Apr 26 02:15  fc_esxtest_systems_hourly_2012-04-26_0215+0200

  3% ( 0%)    1% ( 0%)  Apr 26 00:16  fc_esxtest_systems_hourly_2012-04-26_0015+0200_1

  3% ( 0%)    1% ( 0%)  Apr 26 00:15  fc_esxtest_systems_hourly_2012-04-26_0015+0200

netapparray01> snap sched fc_esxtest_systems

Volume fc_esxtest_systems: 0 2 6@8,12,16,20

netapparray01> vol options fc_esxtest_systems

nosnap=on, nosnapdir=off, minra=off, no_atime_update=off, nvfail=off,

ignore_inconsistent=off, snapmirrored=off, create_ucode=on,

convert_ucode=on, maxdirsize=73400, schedsnapname=ordinal,

fs_size_fixed=off, guarantee=none, svo_enable=off, svo_checksum=off,

svo_allow_rman=off, svo_reject_errors=off, no_i2p=on,

fractional_reserve=0, extent=off, try_first=volume_grow,

read_realloc=off, snapshot_clone_dependency=on, dlog_hole_reserve=off,

nbu_archival_snap=off

But we just notice a strange reaction... VMware snapshot is also still generated (VM snapshot...). That's really strange.

Here is the process we followed:

Uninstall completely DFM version 5.0

reinstall V 5.0 (on the same server...)

Re add vcenter host service

Noticed that snapshots are still running even if there's no configuration anymore on OC/DFM...

It should be a "ghost" configuration running somewhere from the old implementation that we cannot find.


Any idea?

Thanks

Renaud

Re: DFM snapshot issue

We also don't re-install the host package on the vCenter... and in the log we can see that the old dataset are mentionned for snapshot tasks... So is the host package "keeping a local configuration" and is able to launch snapshot alone? Or do it receive the order from the Core for all tasks??

Thanks

Re: DFM snapshot issue

Hello,

We finally solved this by re-installing the Host Package on the vCenter. It seems that the Host Package kept the old DFM configuration and was still triggering VMware snapshots.

Thanks

Renaud

Re: DFM snapshot issue

HI,

In such cases you need to regenerate ssl certificate at DFM side and from HS powershell commandlet you need to tie up with that new certificate of DFM. However you have solved the issue by reinstalling HS.