Subscribe

Data ONTAP SMI_S 5.2 doesn't report LUN latencies

[ Edited ]

Hi!

 

We're running IBM TPC 5.2.4 with a number of N-series clusters (NetApp V-series). We can add those clusters to TPC by using NetApp SMI-S agent. 

We have version /usr/ontap/smis/pegasus/bin/smis version
ONTAP_SMIAgentSoftware.InstanceID="ONTAP:5.2".

 

but we don't get any latency values for FC-LUNs. All ither like bandwidht and IOPS are fine. I opened ticket to IBM about this ages ago and now they've claming that:

 

"

Update from TPC development:
I involved a developer teammate who has the best knowledge in this area and looks like we are not receiving latency values from NetApp, that's why they do not appear.
Here is his answer bellow :
"I tend to agree with the customer, but this is not due to any lack of support by TPC. 
The problem is a lack of support by the NetApp SMI-S provider, which does not support I/O time counters. 
I would recommend that the customer, if they are willing, take this up with NetApp, to request that the necessary support is added to their SMI-S provider. 
Most other storage system vendors do make latency values available via SMI-S, so another alternative would be to replace the NetApps with competitive storage systems, though I expect that won't really be an acceptable option. 
The only other choice is to use software which does not rely on the NetApp SMI-S provider like TPC does.

"

Is this really the case that NetApp SMI-S agent doesn't provide any latency values for LUN's?

 

Best Regards, MiikaP

 

 

Re: Data ONTAP SMI_S 5.2 doesn't report LUN latencies

Guys, I took a look into SNIS-spec itself and it seems that latency is not even part of SNIA spec for SMI-S 1.5. 

 

Rgds, MiikaP