Subscribe

Disk assignment issue after a fresh new configuration FAS2552

Hello,

 

I got a big problem on my FAS2552. Indeed after 2 weeks not powered on the root filer has been corrupted when i'll reboot my material. I can't access to anything so i've made a fresh new configuration (in the start menu, choice : 4 etc...)

 

Now I've just finished my cluster configuration but I have a disk assignment problem , you could see there it's a 24 disks shelf. All of my 24 disks have an owner (even if it's not a 50/50 owner as i wanted, anyway...)

Roval_Cluster_01::*> disk show
                     Usable           Disk    Container   Container
Disk                   Size Shelf Bay Type    Type        Name      Owner
---------------- ---------- ----- --- ------- ----------- --------- --------
1.0.0               836.9GB     0   0 SAS     shared      aggr0_N02 Node_02
1.0.1               836.9GB     0   1 SAS     shared      aggr0_N02 Node_02
1.0.2               836.9GB     0   2 SAS     shared      aggr0_N02 Node_02
1.0.3               836.9GB     0   3 SAS     shared      aggr0_N02 Node_02
1.0.4               836.9GB     0   4 SAS     shared      aggr0_N02 Node_02
1.0.5               836.9GB     0   5 SAS     shared      aggr0_N01 Node_01
1.0.6               836.9GB     0   6 SAS     shared      aggr0_N02 Node_02
1.0.7               836.9GB     0   7 SAS     shared      aggr0_N01 Node_01
1.0.8               836.9GB     0   8 SAS     shared      aggr0_N02 Node_02
1.0.9               836.9GB     0   9 SAS     shared      aggr0_N01 Node_01
1.0.10              836.9GB     0  10 SAS     shared      aggr0_N02 Node_02
1.0.11              836.9GB     0  11 SAS     shared      aggr0_N01 Node_01
1.0.12              836.9GB     0  12 SAS     shared      aggr0_N02 Node_02
1.0.13              836.9GB     0  13 SAS     shared      aggr0_N01 Node_01
1.0.14              836.9GB     0  14 SAS     shared      aggr0_N02 Node_02
1.0.15              836.9GB     0  15 SAS     shared      aggr0_N01 Node_01
1.0.16              836.9GB     0  16 SAS     shared      -         Node_02
1.0.17              836.9GB     0  17 SAS     shared      aggr0_N01 Node_01
1.0.18              836.9GB     0  18 SAS     shared      aggr0_N01 Node_01
1.0.19              836.9GB     0  19 SAS     shared      aggr0_N01 Node_01

                     Usable           Disk    Container   Container
Disk                   Size Shelf Bay Type    Type        Name      Owner
---------------- ---------- ----- --- ------- ----------- --------- --------
1.0.20              836.9GB     0  20 SAS     shared      -         Node_02
1.0.21              836.9GB     0  21 SAS     shared      aggr0_N01 Node_01
1.0.22              836.9GB     0  22 SAS     shared      -         Node_02
1.0.23              836.9GB     0  23 SAS     shared      -         Node_01
24 entries were displayed.

Roval_Cluster_01::*>

But when i check the disk into the aggregate , it only print 14 disks (13 for one node 1 for the other)

 

Roval_Cluster_01::> storage aggregate show-spare-disks

Original Owner: Node_01
 Pool0
  Partitioned Spares
                                                            Local    Local
                                                             Data     Root Physical
 Disk                        Type     RPM Checksum         Usable   Usable     Size Status
 --------------------------- ----- ------ -------------- -------- -------- -------- --------
 1.0.23                      SAS    10000 block           783.0GB  53.88GB  838.4GB zeroed

Original Owner: Node_02
 Pool0
  Partitioned Spares
                                                            Local    Local
                                                             Data     Root Physical
 Disk                        Type     RPM Checksum         Usable   Usable     Size Status
 --------------------------- ----- ------ -------------- -------- -------- -------- --------
 1.0.0                       SAS    10000 block           783.0GB       0B  838.4GB zeroed
 1.0.1                       SAS    10000 block           783.0GB       0B  838.4GB zeroed
 1.0.2                       SAS    10000 block           783.0GB       0B  838.4GB zeroed
 1.0.3                       SAS    10000 block           783.0GB       0B  838.4GB zeroed
 1.0.4                       SAS    10000 block           783.0GB       0B  838.4GB zeroed
 1.0.6                       SAS    10000 block           783.0GB       0B  838.4GB zeroed

Original Owner: Node_02
 Pool0
  Partitioned Spares
                                                            Local    Local
                                                             Data     Root Physical
 Disk                        Type     RPM Checksum         Usable   Usable     Size Status
 --------------------------- ----- ------ -------------- -------- -------- -------- --------
 1.0.8                       SAS    10000 block           783.0GB       0B  838.4GB zeroed
 1.0.10                      SAS    10000 block           783.0GB       0B  838.4GB zeroed
 1.0.12                      SAS    10000 block           783.0GB       0B  838.4GB zeroed
 1.0.14                      SAS    10000 block           783.0GB       0B  838.4GB zeroed
 1.0.16                      SAS    10000 block           783.0GB  53.88GB  838.4GB zeroed
 1.0.20                      SAS    10000 block           783.0GB  53.88GB  838.4GB zeroed
 1.0.22                      SAS    10000 block                0B  53.88GB  838.4GB zeroed
14 entries were displayed.

What should be wrong with my configuration ?

+ why do i have 2 aggr0 on my system ? i thought it was only one root aggr0 for the entire system ?

 

Thanks !

 

Re: Disk assignment issue after a fresh new configuration FAS2552

it's ok i think i've solved my issue. !