Subscribe

FAS3210 migration to clustered 8.2 and problem with cluster interconnect (c0x)

Hi,

 

We have a FAS3210 which I have migrated from 7-mode to 8.2 clustered mode by initializing the disks. Now when I enter the cluster setup wizard I get a question about which ports I'd like to use for the private cluster communcations. I can't enter c0a and c0b which where used in 7-mode but only the e0a, e0b cards or my new e2* 10-gbit cards. 

 

How can I use the c0a and c0b for the cluster communations?

 

Any options that I need to enter? Did I do something wrong when installing 8.2 clustered mode?

 

--- cut >---

 

 

Welcome to the cluster setup wizard.

 

You can enter the following commands at any time:

  "help" or "?" - if you want to have a question clarified,

  "back" - if you want to change previously answered questions, and

  "exit" or "quit" - if you want to quit the cluster setup wizard.

     Any changes you made before quitting will be saved.

 

You can return to cluster setup at any time by typing "cluster setup".

To accept a default or omit a question, do not enter a value.

 

 

Do you want to create a new cluster or join an existing cluster? {create, join}:

create

 

 

Do you intend for this node to be used as a single node cluster? {yes, no} [no]:

 

Will the cluster network be configured to use network switches? [yes]:

no

 

 

Step 1 of 5: Create a Cluster

You can type "back", "exit", or "help" at any question.

 

List the private cluster network ports: c0b

 

c0b is not a valid port.

 

The cluster network ports are the physical ports on the controller that connect

it to the private cluster network. The controller routes cluster network

traffic over these ports by using associated cluster logical interfaces (LIFS).

Examples of cluster network ports in Data ONTAP are "e0a" and "e0b".

 

You can type "back", "exit", or "help" at any question.

 

List the private cluster network ports: quit

Exiting the cluster setup wizard. Any changes you made have been saved.

 

 

The cluster administrator's account (username "admin") password is set to the system default.

 

 

Warning: You have exited the cluster setup wizard before completing all

of the tasks. The cluster is not configured. You can complete cluster setup by typing

"cluster setup" in the command line interface.

 

---< cut >---

Re: FAS3210 migration to clustered 8.2 and problem with cluster interconnect (c0x)

c0a & c0b are used for cluster failover just like they were used in 7 mode.  It is asking for your cluster interconnect ports which would go to your switches if you were using them.  But since your not you just connect them to each other on each controller.  Here is the cabling diagram  https://library.netapp.com/ecm/ecm_download_file/ECMP1213632

 

Re: FAS3210 migration to clustered 8.2 and problem with cluster interconnect (c0x)

Im not getting it. I also have a FAS2240 which doesn't have the c0a and c0b interface. It uses the 10gbit e1a and e1b for a LIF called clus1 and clus2. Here my data is over the 1Gbit e0a to e0d. In my FAS3210 I want to use c0a and c0b for clus1 and clus2 and use e2a och e2b (my 10gbit) for data and leave the e0a and e0b (1gibt) unconnected. Is that not possible? And I need to use the e0a and e0b for the intercluster ports? How does this configuration relate to my FAS2240. I am *confused*. -J

Re: FAS3210 migration to clustered 8.2 and problem with cluster interconnect (c0x)

Remember that cluster mode allows for Clusters of HA pairs. Your 3210 controllers still require the HA connnection on c0a and c0b as in 7-mode, but the cluster setup requires additional 10Gb connectivity. Usually this is to a cluster switch so that multiple HA pairs can be clustered together.

 

As Chester said, if you only want a 2 node cluster you can connect these ports together.

 

On your 2240 system, as this is 2node in a single chassis the HA connection (c0a and c0b) is internal.

 

Cheers

G

Re: FAS3210 migration to clustered 8.2 and problem with cluster interconnect (c0x)

Some NetApp controller use an internal connection to connect the HA pair, the 3210 does not and needs those ports for the HA failover connection.  I believe best practice is to use 10G ports for the cluster interconnect, but I have seen the 1G ports used when that's all there was.  If you want to use e2a & e2b for data, why can't you use e1a & e1b for the cluster interconnects?

Re: FAS3210 migration to clustered 8.2 and problem with cluster interconnect (c0x)

Sorry, meant if you want to use e1b & e2b for data, use e1a & e2a for cluster interconnect

Re: FAS3210 migration to clustered 8.2 and problem with cluster interconnect (c0x)

So as I understand it this would be the configuration: c0a and c0b for HA failover e0a and e0b (1 gbit) for cluster network e2a and e2b (10 gbit) for data And I wanted to move the e0a and e0b to c0a/c0b for speed which is not possible in this controller. And in the FAS2240-4 the HA failover and cluster network both goes over the e1a/e1b (10 gbit mezznine card) .

Re: FAS3210 migration to clustered 8.2 and problem with cluster interconnect (c0x)

If I was going to a customer site to set this up, which is what I do for NetApp, I would do this:

 

Node 1       c0a     c0b     e1a     e2a   

                   to        to      to        to   

Node2        c0a     c0b     e1a      e2a   

 

e1b & e2b on both nodes would go to the network data switches.

Re: FAS3210 migration to clustered 8.2 and problem with cluster interconnect (c0x)

Hi,

 

c0a and c0b is connected to the other node using the backplane. In the FAS3210 they are integrated.

 

I dont have any e1* in my FAS3210 only e0* and e2*.

 

And can you then share e2a och e2b for cluster and data trafic?

 

-J

Re: FAS3210 migration to clustered 8.2 and problem with cluster interconnect (c0x)

I'm sorry, I thought you had cards in slot 1 & 2.  You are going to have to use e2a & e2b for your cluster interconnect and e0a & e0b for data.  You can not share them. Or put in another 10g card.