Community

Subscribe
Highlighted

Failed to initialize Zapi runner OEM Plugin 12.1.0.2.0

[ Edited ]

Hi,

 

I have added my production filer in a 7 System Mode and getting the below error. Any known issues ?

 

Thanks

Suresh Rajagopal

 

[2013-10-01 21:49:09,426] [main] [ERROR] Failed to initialize Zapi runner. Unexpected HTTP response code received for system-get-ontapi-version from <fname>: 503

[2013-10-01 21:49:10,359] [main] [ERROR] Failed to initialize Zapi runner. Unexpected HTTP response code received for system-get-ontapi-version from <fname>: 503

Re: Failed to initialize Zapi runner OEM Plugin 12.1.0.2.0

Hi Suresh,

We are facing this issue first time, hence, we request for following details to troubleshoot this issue further.

1) At the time of registration of storage controller to OEM, default port is 443. User has the option there to change the port number. Is the communication allowed on this port from the host on which agent has been deployed? Please confirm with storage admin.

2) Please confirm with Storage admin if he has given privileges to oemplugin user to access the storage controller on HTTPS port 443

3) Please send the NetAppPlugin.log file for further troubleshooting.

Regards,

Sachin Maheshwari

Re: Failed to initialize Zapi runner OEM Plugin 12.1.0.2.0

Hi Sachin,

We have customized our port to 9999. I have verified the port 9999 access from the server, where i have my agent installed.

Here is the output for filer privilieges.

isops2 16:54:58 ~ $ ssh root@filername useradmin user list oemplugin

root@filername's password:

Name: oemplugin                      

Info:

Rid: 131122

Groups: oemplugingrp

Full Name:

Allowed Capabilities: login-*,api-system-get*,api-volume-list*,api-aggr-list*,api-snapmirror-get-status*,api-snapshot-reserve-list*,api-disk-list*,api-qtree-list*,api-license-list*,api-perf-object*,api-snapshot-list-info*,api-nfs-status*,api-cifs-status*,api-net-ifconfig-get*,api-quota-report*,api-snapshot-list*,api-ems-autosupport-log*,api-cf-status*,api-snmp-get*

Sent the netappplugin.log file to your mail id.

Thanks

Suresh Rajagopal

Re: Failed to initialize Zapi runner OEM Plugin 12.1.0.2.0

[2013-10-01 21:57:05,303] [main] [ERROR] Failed to initialize Zapi runner. Unexpected HTTP response code received for system-get-ontapi-version from filername: 503

[2013-10-01 21:57:06,241] [main] [ERROR] Failed to initialize Zapi runner. Unexpected HTTP response code received for system-get-ontapi-version from filername: 503

[2013-10-01 21:58:07,326] [main] [ERROR] Failed to initialize Zapi runner. Unexpected HTTP response code received for system-get-ontapi-version from filername: 503

[2013-10-01 21:58:33,668] [main] [ERROR] Failed to initialize Zapi runner. Unexpected HTTP response code received for system-get-ontapi-version from filername: 503

[2013-10-01 21:58:34,625] [main] [ERROR] Failed to initialize Zapi runner. Unexpected HTTP response code received for system-get-ontapi-version from filername: 503

[2013-10-01 21:59:11,058] [main] [ERROR] Failed to initialize Zapi runner. Unexpected HTTP response code received for system-get-ontapi-version from filername: 503

Re: Failed to initialize Zapi runner OEM Plugin 12.1.0.2.0

Hi Suresh,

Thank you for sending details.

We need to perform following steps now to drill down this problem further. I suspect this problem from oemplugin user account configuration issue or storage admin might have applied some security settings that is restricting access to controller. Can you please check:

1) Please confirm with storage admin that you are registering physical storage controller with OEM. vfilers are NOT supported for monitoring from OEM.

2) Are you able to launch filer view for user oemplugin? Just type: https://<FilerName/IP>/na_admin. After doing this, it will prompt for user name and password. Please give oemplugin username and password and you should be able to view volumes list. If it doesn't work, only storage admin can help to resolve this permissions problem with user account.

3) Can you ask storage admin to send the output of following command: "options httpd". This command can be executed from controller command prompt using root user account.

4) Can you try: if you can register storage controller with root permissions of controller if storage admin allows to do? He can register storage controller from OEM plug-in GUI rather than sharing credentials with you. If this succeeds, it is problem with oemplugin user permission issue.

Based upon your response, we will try to figure out problem. If it doesn't solve, we may require to setup webex call to troubleshoot further.

Regards,

Sachin Maheshwari