Subscribe

Folder not showing on CIFS

[ Edited ]

Hi,

 

I have noticed a strange behaviour regarding folders inside shares hosted on a CIFS SVM that is runnung on a 2 node clustered FAS2552.

 

I have deployed the user home folders on this CIFS. Recently a user has requested some data from administration, that should be stored in his home drive. So i have created a new folder and put the data in the users folder (\\filer\home$\someuser\datafolder). When the user opens his home drive (mapped by the ms active directory on logon) he doesn't see the folder on his drive and is not able to access it by direct accessing (neither by \\filer\home$\someuser\datafolder nor by h:\datafolder). After a few minutes, the folder was appearing to the user.

 

Is this an expected behavior with CDOT due to the clustering of data? If not, what may cause this effect?

 

Kind regards,

Sascha

Re: Folder not showing on CIFS

Sorry but this doesn't make sense to me

 

Are you saying you enabled dynamic home drives, by enabling home-directory feature and enabling search paths?  Thats the first thing i need to clear up.

 

Based onw what you said, none of this should be an issue. 

 

 

Re: Folder not showing on CIFS

Hello,

 

no, I am not saying that I have enabled the dynamic home drive feature. The home is a standard shared folder on the cifs svm.

 

Kind regards

 

 

Re: Folder not showing on CIFS

First, you should look into the dynamic home directory feature.  

 

Second, your setup with a share like you presented looks ok.  

 

There is really no explanation unless something is configured wrong on your side

Re: Folder not showing on CIFS

[ Edited ]

Hi Sascha,

 

Is it possible that ABE is enabled on your share "home$"? Do they have NTFS permissions to access the data?

This might explain the behaviour you are seeing if the user does not have permissions and ownership. See the following KB article:

 

https://kb.netapp.com/support/s/article/ka21A0000000kI4QAI/how-does-access-based-enumeration-abe-work?language=en_US

 

Have you tried reseting NTFS permissions and file ownship on the folder in the users home directory you copied for them and ensure those permissions and file ownership are inherited to all files subfolders within the directory?

 

/Matt

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.