Subscribe

High CPU HOSTOS process

The system was upgraded last week from Ontap 8.2.1 to 8.3.2P6. The upgrade went smoooth with no problems. Clients can access the NetApp. But when i look at the NetApp with Grafana/Harvest tool i see the CPU  being high, mainly by one process. I looked up what HOSTOS does but it does not explain how or why this process is at 667%. Anybody a idea?

 

 

hostOSTasks owned by the BSD layer including NTP, environmental sensor monitoring, ZAPI handling, autosupport

 

hostos.JPG

Re: High CPU HOSTOS process

did you ever find the cause or resolve the issue?

Re: High CPU HOSTOS process

Nope problem is still there. NetApp suggested that is was solved in version 8.3.2P9. But after upgrading to that version hostOS is still at a abnormal %. I have reopend the case several times (and made new ones linking to the old one) cause the case was closed time after time.

Re: High CPU HOSTOS process

Have you tried dropping into the node shell and running a systat -M?

 

(node run <node-name>; priv set diag; sysstat -M)

 

Dump the output to something where the text doesn't wrap so you can line up the data fields with the columns.  It might help you zero in on the part of HostOS that is chewing through CPU.

 

In the end, you could also re-open your case and do a perfstat gather.  The new perfstat tool is exceedingly easy to use compared to the CLI version and we were able to sleuth out our odd performance behavior case a while back with the assistance of someone on the performance team.

 

Good luck!

 

Chris