Subscribe

How can I disable quotas when using provisioning manager ?

Need some help with provisioning manager,

I need to build a flexvol with a bunch of qtree's but I don't want quotas to be enabled,

dfpm dataset create dataset -v Default -r vfiler1 share1

dfpm dataset provision -n qtree1 -s 10g share1

dfpm dataset provision -n qtree2 -s 10g share1

dfpm dataset provision -n qtree3 -s 10g share1

the result is that I get a flexvol 'share1' with a total size of 30GB, 3 qtree's with hard quotas enforced at 10GB each.

How can I get provisioning manager to increase the flexvol size when I add a new qtree to the dataset but not enforce a quota ?

Re: How can I disable quotas when using provisioning manager ?

Provisioning manager always sets hard quota limits on the Qtress created. There is no option to change it. If you want to change it, you can write a small script and put it in the post provisioning script path.

Ouotas are not monitored for conformance, hence your dataset will remain conformant.

warm regards,

Abhishek

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.