Subscribe

How do i enable an ifgrp in clustered mode

Hi 

 

Can someone help me with the command to enable an ifgrp in cluster mode (cdot). I currently have an ifgrp which entered a disabled state and if i run the command 'ifgrp show' i get 'active ports = none' on the ifgrp with the fault. All other ifgrps have 'activeports = full' and list their associated ports. There doesn't seem to be an option to enable the ifgrp from system manager. 

 

Thanks in advance

Re: How do i enable an ifgrp in clustered mode

 

Singhz -

 

Add physical ports to the ifgrp ?

 


I hope this response has been helpful to you.

 

At your service,

 

Eugene E. Kashpureff, Sr.
Independent NetApp Consultant http://www.linkedin.com/in/eugenekashpureff
Senior NetApp Instructor, FastLane US http://www.fastlaneus.com/
(P.S. I appreciate 'kudos' on any helpful posts.)

 

Re: How do i enable an ifgrp in clustered mode

Hi

 

Thanks for your response. I have 2 ports, e0c and e0d as part of the ifgrp configured as LACP, which was working for quite some time until last week the ifgrp had become disabled. e0c and e0d show in the up status. I can't see anyway to enable the ifgrp..

 

 

Re: How do i enable an ifgrp in clustered mode

if i run a 'network port ifgrp show' i get the following output....see how the active ports show 'none' on the first node

 

 

clstn1::*> network port ifgrp show
              Port       Distribution                             Active
Node     IfGrp      Function     MAC Address       Ports   Ports
-------- ---------- ------------ ----------------- ------- -------------------
clstn1-01
         a0a      ip           *****************                none    e0c, e0d
         a0m      port         *****************                 full    e0f
clstn1-02
         a0a      ip           *****************                   full    e0c, e0d
         a0m      port         *****************                 full    e0e
4 entries were displayed.

Re: How do i enable an ifgrp in clustered mode

 

It looks like those interfaces are both down.

 

Check physical connectivity and configuration on the switch ?

 


I hope this response has been helpful to you.

 

At your service,

 

Eugene E. Kashpureff, Sr.
Independent NetApp Consultant http://www.linkedin.com/in/eugenekashpureff
Senior NetApp Instructor, FastLane US http://www.fastlaneus.com/
(P.S. I appreciate 'kudos' on any helpful posts.)

 

Re: How do i enable an ifgrp in clustered mode

Both ports on the netapp and their corresponding switch port connection show as status up. I've just tried taking one port out of the ifgrp and creating a new ifgrp in single mode and i get connectivity. I'm now thinking it's a problem with LACP on our switches which our networking guys said everything was fine when they checked it.

 

Any other suggestions?

Re: How do i enable an ifgrp in clustered mode

Hi @Singhz

 

If you are using LACP ifgrp on NetApp you must configure LACP configuration on switch side. Please ask you Network team to check the configuration from their side.

Re: How do i enable an ifgrp in clustered mode

LACP config on the switches all look fine. By taking 1 port out of the ifgrp and creating a single mode ifgrp with one port, the switch stats show this port as being detached, which i'm told is what you would see if there is misconfiguration. So switch is configured correctly for LACP but the Netapp ports / ifgrp is misbehaving for some weird reason.

Re: How do i enable an ifgrp in clustered mode

Hi @Singhz

 

Please check broadcast-domain and ipspace details.

Re: How do i enable an ifgrp in clustered mode

Probably preaching to the choir, but be sure to validate your settings and your port configuration(s):

 

 

 

net port ifgrp show -node clstn1-01 -ifgrp a0a -instance
net port show -node clstn1-01 -port e0c,e0d -instance

 

If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO.