Subscribe

How to avoid guarantee=volume(disabled) problem?

Hi,

I have a FAS270 system with ONTAP 7.3.1 on it with the following configuration:

aggr status -r
Aggregate aggr0 (online, raid_dp) (block checksums)
  Plex /aggr0/plex0 (online, normal, active)
    RAID group /aggr0/plex0/rg0 (normal)

      RAID Disk Device  HA  SHELF BAY CHAN Pool Type  RPM  Used (MB/blks)    Phys (MB/blks)
      --------- ------  ------------- ---- ---- ---- ----- --------------    --------------
      dparity   0b.32   0b    2   0   FC:A   -  ATA   7200 635555/1301618176 635858/1302238304
      parity    0b.33   0b    2   1   FC:A   -  ATA   7200 635555/1301618176 635858/1302238304
      data      0b.34   0b    2   2   FC:A   -  ATA   7200 635555/1301618176 635858/1302238304
      data      0b.35   0b    2   3   FC:A   -  ATA   7200 635555/1301618176 635858/1302238304
      data      0b.36   0b    2   4   FC:A   -  ATA   7200 635555/1301618176 635858/1302238304
      data      0b.37   0b    2   5   FC:A   -  ATA   7200 635555/1301618176 635858/1302238304
      data      0b.38   0b    2   6   FC:A   -  ATA   7200 635555/1301618176 635858/1302238304
      data      0b.39   0b    2   7   FC:A   -  ATA   7200 635555/1301618176 635858/1302238304
      data      0b.40   0b    2   8   FC:A   -  ATA   7200 635555/1301618176 635858/1302238304
      data      0b.41   0b    2   9   FC:A   -  ATA   7200 635555/1301618176 635858/1302238304
      data      0b.42   0b    2   10  FC:A   -  ATA   7200 635555/1301618176 635858/1302238304
      data      0b.43   0b    2   11  FC:A   -  ATA   7200 635555/1301618176 635858/1302238304
      data      0b.44   0b    2   12  FC:A   -  ATA   7200 635555/1301618176 635858/1302238304


Spare disks

RAID Disk       Device  HA  SHELF BAY CHAN Pool Type  RPM  Used (MB/blks)    Phys (MB/blks)
---------       ------  ------------- ---- ---- ---- ----- --------------    --------------
Spare disks for block or zoned checksum traditional volumes or aggregates
spare           0b.45   0b    2   13  FC:A   -  ATA   7200 635555/1301618176 635858/1302238304

I would like to create the biggest volume (and LUN) possible, with:

- snapshots disabled (0% reservation set for snapshots, nosnap for the aggr0 and volumes) - already done,

- one spare disk (as shown above) - already done,

- vol0 size reduced to minimum (10GB) - already done.

- size guarantee enabled for the volume,

What is the biggest size i can get without issuing the guarantee=volume(disabled) problem?

Weird thing happened, i had a 5,7T volume (vol1) on it with guarantee enabled for the volume and LUN with the maximum size possible and after some time the guarantee switched to disabled. I've destroyed the LUN and vol1, and now i can create volume with a max size of 3,7T. I've found out that WAFL reserve is taking over about 2,4TB so this is probably the lost free space:

aggr show_space -h
Aggregate 'aggr0'

    Total space    WAFL reserve    Snap reserve    Usable space       BSR NVLOG           A-SIS
         6827GB           682GB             0KB          6144GB             0KB             0KB

Space allocated to volumes in the aggregate

Volume                          Allocated            Used       Guarantee
vol0                                 12GB           649MB          volume

Aggregate                       Allocated            Used           Avail
Total space                          12GB           649MB          3777GB
Snap reserve                          0KB             0KB             0KB
WAFL reserve                        682GB          2407GB             0KB

how can i recover (free) this space and use it in volume? What am i doing wrong?

Re: How to avoid guarantee=volume(disabled) problem?

This space should get freed up after the scrub process has finished in the aggregate. This is the process that goes through and checks every block on the disk and if it is a data block, checks to see if there are any snapshot or filesystem references to it. If there aren't, then it is cleaned and made available as free space. This can take some time, and so you should see this storage slowly become available.

Are you definitely disabling the snapshots in the volume you are creating?

You could also look at removing the aggregate snapshots and schedule. Although not best practice, it seems like you are looking to maximise your storage capacity rather than make use of online backups anyway?

Re: How to avoid guarantee=volume(disabled) problem?

Yes, you are right, the space did get freed (i think there should be some message with information about this process, when you destroy volume - it would be less confusing).

Snapshots are definitely off:

snap reserve -A aggr0 0

snap reserve -V vol0 0

snap reserve -V vol1 0

options aggr nosnap 1

options vol0 nosnap 1

options vol1 nosnap 1

How can i remove schedule?

I don't need online backups, maximum storage is more important for me.

Re: How to avoid guarantee=volume(disabled) problem?

snap sched -A aggr0 0

snap sched -V vol1 0

I actually would recommend keeping a minimal snapshot configuration on the vol0, you want some level of protection here, even if it's only once a day for 2 days.

I agree that there should be some more useful information regarding the space getting freed up slowly. Often it is not too obvious and if you leave it overnight, it's magically all there the next day! This is only really obvious when you delete large volumes or have a very busy filer however. I believe "aggr status -r" shows the scrub process if it is in the middle of a job.

Hope this has helped.