Subscribe
Accepted Solution

How to set IP address on e0P interface on FAS2040

Hello everyone,

As the title says, I'm trying to change the IP address of the e0P interface on my FAS2040 (Data ONTap 8.0.2 7-mode) but I get an error message saying: "private interface cannot be modified through cli". I should mention this is the e0P interface on the second controller of my FAS2040. When I run the ifconfig e0P command this is the result:

e0P: flags=0x2348867<UP,BROADCAST,RUNNING,MULTICAST,TCPCKSUM> mtu 1500 PRIVATE

        inet 192.168.0.210 netmask 0xfffffc00 broadcast 192.168.3.255 noddns

        ether 00:a0:98:4c:41:d6 (auto-unknown-down) flowcontrol full

You can see the interface is set to Private...how can I change that? I want to be able to configure the interface.

I was able to configure the e0P interface on the first controller without any issues, it wasn't set to private...why is the e0P interface on the second controller set to private?

Re: How to set IP address on e0P interface on FAS2040

This is the alternate control path for sas shelves. It auto configures. Do not modify it. just enable acp

Re: How to set IP address on e0P interface on FAS2040

You can change network used for ACP using “acpadmin configure” command

While it is theoretically possible to disable ACP and use e0P as normal interface, I am not sure whether this is really supported configuration. At least, open case with NetApp support to confirm it.

Re: How to set IP address on e0P interface on FAS2040

AFAIK it is air-gapped from anything else, so probably not much value in tinkering with the address.

Re: How to set IP address on e0P interface on FAS2040

It runs in separate ip-space when used as ACP; but I do not think it is physically separated otherwise.

Re: How to set IP address on e0P interface on FAS2040

There were some weird bugs early in but all good now in latest ontap. We hit an odd wins bug in the e0P port early on

Sent from my iPhone 4S

Re: How to set IP address on e0P interface on FAS2040

How come the e0P interface on the first controller is not private and on the second controller it is?

How can I disable ACP? I would like to use e0P as a normal interface

Re: How to set IP address on e0P interface on FAS2040

Yeah, I should put quotation marks around 'air-gapped' I meant e0P can't be really used / connected to anything else than isolated ACP network.

Re: How to set IP address on e0P interface on FAS2040

It can be disabled with options acp.enabled off but not sure why one node is private and the other isn't. It isn't meant for non acp use and also is only a 100mbit port.