Subscribe

I loaded MCTB 2.2.2 and getting the following errors...

/opt/NTAPdfm/script-plugins/MetroCluster-TieBreaker/mctb_dfm.sh: line 51:

/opt/NTAPdfm/script-plugins/MetroCluster-TieBreaker/mctb_dfm.sh: line 57:

These is is in the script mctb_dfm.sh.

Line 51  ./NTAPmctb status > /dev/null

Line 57 ./NTAPmctb start > /dev/null

I didn’t a find in the directory MetroclusterTiebreaker this file  NTAPmctb:   find: `NTAPmctb': No such file or directory

I also tried 2.1.1 and 2.1.2  with the same error

What can I do about this?

Scott Tribbey

Re: I loaded MCTB 2.2.2 and getting the following errors...

Hi Scott,

     How was MCTB installed?

     Was the "install" command run?

The NTAPmctb script gets created when the "install" command is run, after the installation through Operations Manager.  What OS are you running on?

Thanks,

Brian

Re: I loaded MCTB 2.2.2 and getting the following errors...

Through OnCommand followed the AdminGuide.pdf

Yes, the install was run

Scott Tribbey

General Electric

Office Phone – 321-435-5465

e-mail – scott.tribbey@ge.com

Re: I loaded MCTB 2.2.2 and getting the following errors...

Through OnCommand followed the AdminGuide.pdf

Yes, the install was run

The NTAPmctb script gets created when the "install" command is run, after the installation through Operations Manager.  What OS are you running on?

Linux  -- RHEL 6

Re: I loaded MCTB 2.2.2 and getting the following errors...

Run the install command manually from the script-plugin directory and see what errors are shown:

  1. cd /opt/NTAPdfm/script-plugins/MetroCluster-TieBreaker
  2. ./mctb_dfm.sh install
  3. Ensure NTAPmctb exists, and has execute permissions (555)

If not, please send me any error messages the install command issued.

Thanks,

Brian

Re: I loaded MCTB 2.2.2 and getting the following errors...

I ran it from OnCommand server and it worked.  Thanks for the help --  Do you know why it was not working from the console?

Another question:   I put the password in encryptedPassword but not encrypted format.  Before, it used to encrypt the password after I restarted MCTB -- not doing it now

Scott tribbey

Re: I loaded MCTB 2.2.2 and getting the following errors...

You could go back to the job in Operations Manager that you created to invoke the "install" command and check the output there.  There should be an error message if something failed.

You never use the element <encryptedPassword> yourself.  When you set the password, or change it in the future, you replace the <encryptedPassword> element with <password> and provide the new password in clear text.  Then run "validate" or stop/start MCTB.  This will immediately rewrite the config file and replace the <password> element and clear text password with the <encryptedPassword> element and the encrypted password text.

Glad this was resolved.  Let me me know if you have any further questions or problems.

Brian

Re: I loaded MCTB 2.2.2 and getting the following errors...

Another issue --

2014-04-28 19:47:45,350 [filerStatusUpdate-1] ERROR com.netapp.rre.anegada.Monitor - Can't connect to controller pd1ns01t: null

2014-04-28 19:47:45,350 [filerStatusUpdate-2] ERROR com.netapp.rre.anegada.Monitor - Can't connect to controller pd1ns02t: null

From OnCommand server I can ping both filers and the gateway, and I can connect to both controllers with ssh.

Scott

Re: I loaded MCTB 2.2.2 and getting the following errors...

I getting this error:

2014-04-28 19:55:05,570 [filerStatusUpdate-1] ERROR com.netapp.rre.anegada.Filer - pd1ns01t: ApiException on system-get-info: java.net.ConnectException: Connection refused

2014-04-28 19:55:05,570 [filerStatusUpdate-2] ERROR com.netapp.rre.anegada.Filer - pd1ns02t: ApiException on system-get-info: java.net.ConnectException: Connection refused

Re: I loaded MCTB 2.2.2 and getting the following errors...

Connect Refused means that the TCP port for the API isn't accepting connections.  Check the following:

  • Check that admin API access is enabled:  "options httpd.admin.enable"
  • Check that the setting for <ssl> is correct in the config.xml file (false for HTTP on port 80, true for HTTPS on port 443).
  • If you are using SSL, make sure it's set up and that ssl admin access is enabled: "options httpd.admin.ssl.enable"

If the user you're accessing the controllers as is other than root, check that the appropriate permissions are granted. Appendix B in the Admin Guide has details on the necessary permissions.

Brian