Subscribe
Accepted Solution

In ONTAP 8.3 SAN clients only see 2 of 4 nodes

I rebuilt my 4-node lab cluster the other day using 8.3RC1, and I've run into an odd issue that I hope the community can help me with.  I setup a SAN SVM with both FCP and iSCSI.  I created the requisite volumes, LUNs, portsets, LIFs, igroups, etc. to export an iSCSI and FCP LUN to my CentOS 6 client.  This client had previously mounted FCP and iSCSI LUNs from this cluster when it was 8.2.  I was forced to rebuild this cluster from scratch, so this is essentially a clean build and not an upgrade.

 

My problem is that using either iSCSI or FCP I can see the client login to the filer on all 4 nodes:

 

labcluster::system license> event log show
Time Node Severity Event
------------------- ---------------- ------------- ---------------------------
2/16/2015 21:24:02 labcluster-01 NOTICE scsitarget.fct.portLogin: Login at target FC port:'0a' by initiator port '21:00:00:24:ff:31:46:fe'-addres 0x7d0200. The target virtual port is:'NetApp FC Target Port (2532) san_vserver:labcluster-01_fc_lif_1'.
2/16/2015 21:24:02 labcluster-02 NOTICE scsitarget.fct.portLogin: Login at target FC port:'0a' by initiator port '21:00:00:24:ff:31:46:fe'-addres 0x7d0200. The target virtual port is:'NetApp FC Target Port (2532) san_vserver:labcluster-02_fc_lif_1'.
2/16/2015 21:24:02 labcluster-03 NOTICE scsitarget.fct.portLogin: Login at target FC port:'0a' by initiator port '21:00:00:24:ff:31:46:fe'-addres 0x7d0200. The target virtual port is:'NetApp FC Target Port (2532) san_vserver:labcluster-03_fc_lif_1'.
2/16/2015 21:24:02 labcluster-04 NOTICE scsitarget.fct.portLogin: Login at target FC port:'0a' by initiator port '21:00:00:24:ff:31:46:fe'-addres 0x7d0200. The target virtual port is:'NetApp FC Target Port (2532) san_vserver:labcluster-04_fc_lif_1'.

 

However, on the client side I only see two nodes:

 

[root@san_client ~]# sanlun lun show -p

ONTAP Path: san_vserver:/vol/fcp_volume/lun0
LUN: 0
LUN Size: 100g
Product: cDOT
Host Device: 3600a098051763175562b46746d634345
Multipath Policy: round-robin 0
Multipath Provider: Native
--------- ---------- ------- ------------ ----------------------------------------------
host vserver
path path /dev/ host vserver
state type node adapter LIF
--------- ---------- ------- ------------ ----------------------------------------------
up primary sdf host1 labcluster-01_fc_lif_1
up secondary sde host1 labcluster-02_fc_lif_1

 

 

My SAN is non-redundant, but I should still see 4 paths -- one for each controller.  My client /etc/multipath.conf is setup per NetApp best-practices.

 

I've tried just about everything I can think of to troubleshoot this.  I'm thinking it might be a license issue (licenses are demos from NetApp) that would limit the protocols to 2 nodes.  Has anyone else experienced this?  Is there a way to check the license node limits in 8.3?

 

Thanks!

Re: In ONTAP 8.3 SAN clients only see 2 of 4 nodes

In 8.3 selective lun mapping is enabled by default.

 

In an upgrade scenario, the old behaviour is retained.  

Re: In ONTAP 8.3 SAN clients only see 2 of 4 nodes

I didn't even realize this was a new behavior.  I did find this documentation link that explains the behavior.  Thank you!

 

https://library.netapp.com/ecmdocs/ECMP1636035/html/GUID-62ABF745-6017-40B0-9D65-CE9F7FF66AB3.html