Subscribe
Accepted Solution

Install can't find mtcb_dfm.pl?

Having some trouble installing the Windows version of the MCTB. Hopeful this is something simple I've missed.  Anyone have trouble with the install script finding mctb_dfm.pl?

Step 1 – Install the Operations Manager Script Plugin completes successfully

Step 2 - Running the install script

Causes this error in Operations Manager:

  • Execution of 'perl C:\Program Files\NetApp\DataFabric Manager\DFM\script-plugins\MetroCluster-TieBreaker\mctb_dfm.pl' failed.
  • Reason: The system cannot find the file specified

The reason it can't find the file is that the PATH needs to be quoted.   So, I tried manually running in a cmd prompt as follows

perl "C:\Program Files\NetApp\DataFabric Manager\DFM\script-plugins\MetroCluster-TieBreaker\mctb_dfm.pl" install

   

and then I received the following error:

Installing MCTB Windows Service

===============================

intserv is not recognized as an internal or external command


Screen shots attached of install attempts and  error messages.

Thanks for any help you can provide

-Joyce

Re: Install can't find mtcb_dfm.pl?

Hi Joyce,

It's likely that Perl hasn't been installed on DFM server (Perl is necessary for MCTB on Windows DFM servers).  Please use Active State perl, as we have had problems with other distributions.  Here's a link: http://www.activestate.com/activeperl/downloads

Don't buy anything!  Perl is free, but ActiveState does provide commercial products wrapped around their Perl distro, and sometimes it looks like you need to buy something to get it, but you don't.

Let me know if you have any more questions or issues.

Brian

Re: Install can't find mtcb_dfm.pl?

I downloaded perl yesterday same perl you are indicating – activestate.  The perl version I have 5.16, says has to be higher than 5.10 in doc

On Windows you need double quotes around the path if there are blanks in the path.  That is why it can find the install script.

Also,  I was able to run the script in cmd prompt – and received the other error about “instserv”.   Which says perl is loaded.

Re: Install can't find mtcb_dfm.pl?

Yeah, I never install Perl under Program Files, or any other path with spaces in it.  It causes too many problems.  It's a drag that the default installation directory for the ActiveState installer is under Program Files.

Does that resolve your issue, or are you still having problems?

Re: Install can't find mtcb_dfm.pl?

Perl is not installed under Program Files, the tiebreaker is installed under Program Files.  There is also a space between DataFabric and Manager in the path below. 

C:\Program Files\NetApp\DataFabric Manager\DFM\script-plugins\MetroCluster-TieBreaker\mctb_dfm.pl

Even if I get past the space issues by adding quotes and running mctb_dfm.pl at the command line, I still have the problem where the install script starts to run and then can't find "intserv"

Installing MCTB Windows Service

===============================

intserv is not recognized as an internal or external command


Re: Install can't find mtcb_dfm.pl?

Interesting.  I just now did a scratch install of MCTB on a DFM server running on Windows 2008 R2 and don't see any of these problems.  What version Windows, DFM, and MCTB are you using?

Re: Install can't find mtcb_dfm.pl?

Oh, also, mctb_dfm.pl isn't designed to be run manually, you have to run it from the script interface in Operations Manager.

Re: Install can't find mtcb_dfm.pl?

Thanks for all your responses and hanging in there with me on this issue.  Here are the versions:

Windows: Microsoft Windows Server 2008 R2 Service Pack 1 (Build 7601) x64 based

DFM: 5.1.0.15008 (5.1)

MCTB: mctb-dfm-plugin-windows-2.1.1

Re: Install can't find mtcb_dfm.pl?

And you installed MCTB by using the Operations Manager script installation mechanism, as described in the Admin Guide?

Have you run “install” and “validate” jobs from the OM MCTB script interface?

Re: Install can't find mtcb_dfm.pl?

  1. 1. Did you install MCTB by using the Operations Manager script installation mechanism, as described in the Admin Guide?  Yes
  2. 2. Have you run “install” and “validate” jobs from the OM MCTB script interface? Ran install not validate – just ran validate same error as install