Subscribe

Issue with 8.3 upgrade check powershell script

I'll preface this by saying that I've gotten the powershell script to work on my machine, but I'm having issues getting it installed on a different machine for one of our other team members.  This article details the script we're using: http://community.netapp.com/t5/Virtualization-and-Cloud-Articles-and-Resources/How-to-Check-Data-ONTAP-8-3-2-Upgrade-Requirements-Using-a-PowerShell-S...

 

I think the problem may be in the order that we did things.  We installed the windows managment framework 4.0 and the netapp powershell toolkit before upgrading .net to version 4.5.  We then had to re-install the management framework to get powershell up to version 4, and then we re-installed the netapp powershell toolkit 4.1.0 after that.

 

Whenever we try to run the script, it gives us the error that says it needs to have the ontap powershell toolkit version 3.2.1 or higher.

 

When we run the command: Get-Module -ListAvailable, all of the modules line up exactly with what show on my system, but we still keep running into the error of it needing the ontap powershell toolkit version 3.2.1 or higher.

 

The module list clearly shows that version 3.3.0 of the ontap powershell toolkit is installed. The get-natoolkitversion command throws an error that the module isn't installed though.  We've tried uninstalling and re-installing it, with no change in outcome.  We've also run the import-module DataONTAP and even provided the specific location where the module is, but we still get the same output from get-natoolkitversion.

 

Has anyone hit this issue before?  If so, what did you do to resolve it to be able to run the 8.3 upgrade check script?

 

Just to throw another wrench into the issue, my system is running .net 3.5, but my powershell is on version 4, and the script runs just fine.

 

Thanks in advance for any help.