Subscribe

Migrate data from a single node cluster to a single node cluster with CDOT 8.3

Hi,

 

I have two FAS2240-4 in the office, one for production and the second one intended to use it for DR, the FAS with 18 disk of 2TB each that is in production has 3 disk for the root aggregate and the rest for data, so I need to wipe the system in order to take advantage of the HDD partitioning for the entry platforms in CDOT 8.3.

 

The Second system is fresh installed with CDOT 8.3 with the Root-Data HDD partitioning so now I want to move the Data and configuration to replace the first cluster with the second one.

Some body gave me a procedure to backup the configuration and restore it at the destination cluster but I believe that is not complete. After finish the procedure I have all duplicated and not working properly, even with missed data, so the procedure is:

 

---------------------------------------------------
SYSTEM CONFIGRUATION BACKUPS FOR CLUSTERED ONTAP

SOURCE SYSTEM
---------------------------------
set -priv diagnostic
cluster identiy show
system configuration backup create -backup-name myBackup.7z -node node1 -backup-type cluster (Create a node backup of node1)
system configuration backup upload -node node1 -backup myBackup.7z -destination ftp://username:password@ftp.server.com (Uploads a backup file to ftp)

DESTINATION SYSTEM
---------------------------------
## This would be done after setting up one node on the dr site, but prior to confguring the rest of the nodes
## you would basically stand up the system with ips and a base config, and load the config from the primary site
## and once it comes back up, you would setup & join the other nodes.
set -priv diagnostic
cluster identity show
system configuration backup download -node node1 -backup myBackup.7z -destination ftp://username:password@ftp.server.com
system configuration recovery cluster recreate -from backup -backup myBackup.7z
system node reboot -node node1
cluster identity show
cluster identity modify -name newcluster
cluster identity show
system configutration recovery cluster modify -recovery-status complete

----------------------------------------------------

After doing this then I have problems with the folowing:
- Volumes without properties
- Network interfaces down and mixed with the old and new system
- Aggregates with no info (This table is currently empty)

- The node name is not able to rename it because it says that is already in use.

 

I believe that I need more information in order to complete the procedure well. 

 

I hope that you can help me with this.

 

Best Regards,

 

Miguel Valls