Subscribe

Modify global default snapshot reserve

Hi guys,

I would know if can change the default value of 20% to snapshots reserve space for new volumes. I need that all new volumen, by default, have a snapshot reserve of 0%.

Best regards.

Re: Modify global default snapshot reserve

Did you try changing the desired setting on root vol and then creating new vol? As if I remember well, all new volumes copy snapshot reserve and snapshot schedule from root volume.

Please let me know if that works.

Cheers,

Re: Modify global default snapshot reserve

I am out of the office until 25/03/2012.

I am not available from 23rd to 25th March due to Public Holiday in

Bangalore and I will be out of station . Please reach out to Steve

Lee/India/IBM, for any Solution queries in my absence. For any management

queries please reach out to Sundar Subramanian1/India/IBM.

For emergency I can be reachable on Mobile Numbers - 9900111441 /

9886395241.

I Apologies for any Inconvenience and Thanks in Advance for your

co-operation.

Note: This is an automated response to your message "[Products &

Solutions] - Re: Modify global default snapshot reserve" sent on 23/3/12

19:16:07.

This is the only notification you will receive while this person is away.

Re: Modify global default snapshot reserve

Don´t work:

netapp01> snap reserve vol0 0

netapp01> snap reserve vol0

Volume vol0: current snapshot reserve is 0% or 0 k-bytes.

netapp01> vol create test0 aggr1 50g

Creation of volume 'test0' with size 50g on containing aggregate

'aggr1' has completed.

netapp01> snap reserve test0

Volume test0: current snapshot reserve is 20% or 10485760 k-bytes.

Any suggestions?

Thanks.

Re: Modify global default snapshot reserve

This may seem like a dumb question, but is vol0 the root volume?  vol status vol0 will ensure that someone/something has not changed it.

- Scott

Re: Modify global default snapshot reserve

Yes, vol0 0 is the root volume:

netapp01> vol options vol0

root, diskroot, nosnap=off, nosnapdir=off, minra=off,

no_atime_update=off, nvfail=off, ignore_inconsistent=off,

snapmirrored=off, create_ucode=off, convert_ucode=off,

maxdirsize=20971, schedsnapname=ordinal, fs_size_fixed=off,

compression=off, guarantee=volume, svo_enable=off, svo_checksum=off,

svo_allow_rman=off, svo_reject_errors=off, no_i2p=off,

fractional_reserve=100, extent=off, try_first=volume_grow,

read_realloc=off, snapshot_clone_dependency=off

I can see that the values for snap sched are global, if i change schedules for vol0 next vols that i create has the same sched, but with space reservation for snapshots don´t work.

Release dataOntap 7.3.6

System FAS3020

I tried it on another filer (Release 7.3.4) with the same result.

Can you think of something else?

Thanks.

Re: Modify global default snapshot reserve

Interesting...I just tried it on my 3020s, and found that it shows some interesting output.  Mine shows 0% for the reserve, but shows space allocated!  And re-running the same test gives me the result as you have seen.  Unfortunately the 3020s are passed End of Support, so I doubt there is going to be a patch to fix something of this nature.

filer1> snap reserve vol0

Volume vol0: current snapshot reserve is 20% or 20132656 k-bytes.

filer1> snap reserve vol0 0

filer01> vol create test_schubb aggr1 50g

Creation of volume 'test_schubb' with size 50g on containing aggregate 'aggr1' has completed.

filer1> df -g test_schubb

Filesystem               total       used      avail capacity  Mounted on

/vol/test_schubb/         40GB        0GB       39GB       0%  /vol/test_schubb/

/vol/test_schubb/.snapshot       10GB        0GB       10GB       0%  /vol/test_schubb/.snapshot

mcprst01> snap reserve vol0

Volume vol0: current snapshot reserve is 0% or 0 k-bytes.

- Scott