Subscribe

NFS disconnect, EXSi 5.x performance problem and setting

If you are expereniencing any NFS disconnects or some performance problem and you are running EXSi 5.x then this may help. VMWare made a change between 4.1 and 5.x, the default NFS.MaxQueueDepth was changed from 64 to 4294967295. We run our own benchmark and NetApp told us they ran some,  changing NFS.MaxQueueDepth to 64 increased performance. Others are seeing some NFS disconnects. NetApp told us to run netstat -sp tcp and grep on zero window.

 

“The NFS queue depth, was introduced in 5.0 so that SIOC would work with NFS. VMware (TAM and GSS) provided clear information regarding this during the post-mortem session with VMware and NetApp support engineers. Changing the NFS.MaxQueueDepth to 64 is, in fact, a workaround. Vaughn (NetApp) mentions this as well in his article above stating that “A fix has been released by NetApp engineering and for those unable to upgrade their storage controllers, VMware engineering has published a pair of workarounds” (SIOC or NFS.MaxQueueDepth to 64)”

 

http://cormachogan.com/2013/02/08/heads-up-netapp-nfs-disconnects/

Re: NFS disconnect, EXSi 5.x performance problem and setting

Thanks for the info.. A netapp KB is here, for those who are interested in additional reading..!

https://kb.netapp.com/support/index?page=content&id=2019152

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Cannot find the answer you need? No need to open a support case - just CHAT and we’ll handle it for you.