Subscribe

NFS mount issue in cDOT 8.3.2RC2 - appears to only see the ROOT

Hi, I created a new volume on an existing SVM which is presenting NFS.

 

However, I am seeing the root (/) from the filer - : I think I have set my export-policy up correctly.

Cannot think what I have missed.

 

any ideas/tips appreciated.

 

 

 

[nfstest@llcnfs01v ~]$ showmount -e 10.9.134.217
Export list for 10.9.134.217:
/ (everyone)

 

cat /etc/hosts
127.0.0.1       localhost       localhost.localdomain localhost4 localhost4.localdomain4
10.96.88.113    llcnfs01v.production.local      llcnfs01v
10.9.134.217    filer

 

 

============================================================================

 

 

From the filer side all appears ok:

 

Vserver: PG6-EV

        General Access:  true
                    v3:  enabled
                  v4.0:  enabled
                   4.1:  enabled
                   UDP:  enabled
                   TCP:  enabled

 

Allowed Protocols: nfs, cifs

 

 

LIF:          Vserver Name: PG6-EV
          Logical Interface Name: PG6-EV_NFS_lif1
                            Role: data
                   Data Protocol: nfs

      ..

     Is Home: true
                 Network Address: 10.9.134.217
                         Netmask: 255.255.255.0
             Bits in the Netmask: 24

 

 

Volume:                vol show -inst -vserver PG6-EV -volume vol_test

                                   Vserver Name: PG6-EV
                                    Volume Name: vol_test
                                 Aggregate Name: node04_VNX04
                                    Volume Size: 10GB
                             Volume Data Set ID: 1148
                      Volume Master Data Set ID: 2153876930
                                   Volume State: online
                                    Volume Type: RW
                                   Volume Style: flex
                         Is Cluster-Mode Volume: true
                          Is Constituent Volume: false
                                  Export Policy: rob_test_pol
                                        User ID: 0
                                       Group ID: 0
                                 Security Style: unix
                               UNIX Permissions: ---rwxrwxrwx
                                  Junction Path: /vol_test
                           Junction Path Source: RW_volume
                                Junction Active: true
                         Junction Parent Volume: PG6EV_root

 

 

Export policy rule:

 

Vserver      Name            Index   Protocol Match                 Rule
------------ --------------- ------  -------- --------------------- ---------
PG6-EV       rob_test_pol    1       nfs      10.96.88.113          any

 

Default:

 

rule show -vserver PG6-EV -policyname default
             Policy          Rule    Access   Client                RO
Vserver      Name            Index   Protocol Match                 Rule
------------ --------------- ------  -------- --------------------- ---------
PG6-EV       default         1       nfs3     0.0.0.0/0             any

 

 

 

 

 

 

 

 

 

 

Re: NFS mount issue in cDOT 8.3.2RC2 - appears to only see the ROOT

some additional information.

 

our unix resource mounted /

 

filer:/ on /mnt type nfs (rw,relatime,vers=3,rsize=65536,wsize=65536,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=10.9.134.217,mountvers=3,mountport=635,mountproto=udp,local_lock=none,addr=10.9.134.217)

 

However, I cannot issue commands against this mount

 

ls /mnt, df /mnt, fuser all hang

 

 

[nfstest@llcnfs01v ~]$  sudo /usr/bin/umount -f /mnt
umount.nfs: /mnt: device is busy