Subscribe

NTP not working ..

I have DOT 8.1.4 running on my FAS. NTP was configured and working fine. but now its showing a time difference of about 295Secs.
how can i check the difference b/w filer and time server.

Why filer is not sync its time with NTP server. I can ping the NTP server plus there is no messages in /etc/messages regarding adjusting time ......

options timed are as under:-

 

timed.enable on

timed.log on

timed max_skew 30m

timed.min_skew 0

timed.proto ntp

timed.sched 1hr

timed.window 0s

 

Regards

Re: NTP not working ..

[ Edited ]

have you seen this bug?

http://mysupport.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=459942

 

it's observed in 8.1.4 (without P1) and causes the filer to stop syncing with ntp - try update ontap - perhaps it helps

 

if not you can have a closer look to this KB-article, it helps you verify if ntp-sync works: https://kb.netapp.com/support/index?page=content&id=1010058&locale=en_US

 

-AJ

Re: NTP not working ..

[ Edited ]

I can't open the above document Smiley Sad
how can i ??

plus ... in KB article i don't see any single entry in /etc/log/mlog/messages.log regarding ntp.. Does this mean that NTP is not working?

 

Thanks alot for ur reply.

Re: NTP not working ..

Hi I had a similar issue a month or so back where NTP and SNMP packets were, evidently, not reaching their destinations. The issue turned out to be a routing glitch where these packets were being sent to an unused network interface (ie one that was "up" but should have had no traffic on it). As soon as I removed that interface, the "stray" packets started being sent out of the correct interface and NTP was able to resync. When I was researching this, I found an earlier post from someone who'd run into the same issue and he solved it by repeating the "route add default ..." command (from the /etc/rc file). Good Luck! Richard.

Re: NTP not working ..

it just copy it here for you:

Bug ID

459942
TitleData ONTAP fails to sync with remote NTP server after reboot
Duplicate of 
Bug Severity2 - System barely usable
Bug StatusFixed
ProductData ONTAP
Bug TypeKernel/Op Sys 
Description
Formatted
 In some situations Data ONTAP's NTP service will fail to initialize properly
 on system boot.  As a result the system will not maintain time with remote peers
 and over time the system time will diverge.
Workaround
Formatted
 To workaround the issue add the following entries to the /etc/rc file:
 options timed.enable off
 options timed.enable on
 
 This workaround will force the NTP service to initialize again later in the boot
 process.
 
Notes
Formatted
 Additional NTP troubleshooting steps are in a knowledge base article:
 https://kb.netapp.com/support/index?page=content&id=1010058
 
Fixed-In VersionA complete list of releases where this bug is fixed is available here.

 

as far as i know you want find any log-entry within messages or mlog regarding ntp sync - you have to follow the procedures explained in the KB-article

 

Re: NTP not working ..

Complete list officer version for Bug ID 459942 shows 8.1.4 GA.
By the way, how ntpdc -* in WEEKLY_LOG ASUP shows?