Community

Subscribe
Highlighted

Need help !!! unable to modify or delete LIF on node of a cluster

Hi ,

I am using Netapp cluster mode 8.2 simulator on VMware fusion.

I have set 2 node cluster. The network configurations are fine on one node but the second node is not reachable from the cluster.

clus1::network routing-groups route> network interface show

            Logical    Status     Network            Current       Current Is

Vserver     Interface  Admin/Oper Address/Mask       Node          Port    Home

----------- ---------- ---------- ------------------ ------------- ------- ----

clus1

            cluster_mgmt up/up    192.168.226.10/24  clus1-01      e0c     true

clus1-01

            data_int1    up/up    192.168.199.10/24  clus1-01      e0a     true

            data_int2    up/up    192.168.199.11/24  clus1-01      e0b     true

            mgmt1        up/up    192.168.226.20/24  clus1-01      e0c     true

clus1-02

            clus1        up/-     169.254.246.5/16   clus1-02      e0a     true

            clus2        up/-     169.254.51.137/16  clus1-02      e0b     true

            mgmt1        up/-     192.168.226.11/24  clus1-02      e0c     true

The IP subnet 169.254.0.0/16 does not exist in my system anywhere, so I wanted to change it to 192.168.199.0/24 but it was throing error :

clus1::network interface> modify -vserver clus1-02 -lif clus1 -home-node clus1-02 -home-port e0a -address 192.168.199.20

Error: command failed: Cluster configuration data can only be changed on node where cluster lif resides.

When i tried to delete the LIF then it showed following error :

clus1::network interface> delete -vserver clus1-02 -lif clus1                                                     

Error: command failed: Removing cluster lifs that are part of the sitelist is not permitted

Routing groups are :

clus1::network routing-groups> show

          Routing

Vserver   Group     Subnet          Role         Metric

--------- --------- --------------- ------------ -------

clus1

          c192.168.226.0/24

                    192.168.226.0/24

                                    cluster-mgmt      20

clus1-01

          c192.168.199.0/24

                    192.168.199.0/24

                                    cluster           30

          n192.168.226.0/24

                    192.168.226.0/24

                                    node-mgmt         10

clus1-02

          c169.254.0.0/16

                    169.254.0.0/16  cluster           30

          c192.168.0.0/16

                    192.168.0.0/16  cluster           30

          n192.168.226.0/24

                    192.168.226.0/24

                                    node-mgmt         10

Thanks in advance


Re: Need help !!! unable to modify or delete LIF on node of a cluster

It looks like the first sim is created without a cluster switch.

The second looks dead. No up interfaces at all. To completely verify it try 'network port show'.

The error messages is made by design:

The RDB (replication database) keeps track of what and where the cluster interfaces are. --> Proof of this you can find in 'cluster ping-cluster -use-sitelist true' ...

if you want a working clustered simulator my advise is (unfortenately ... start over again)

download 8.2 simulator

Start installation of node 1 create cluster --> choose for a clusterswitch

Start installation of node 2 join cluster

If you want only 1 cluster port for the simulator (never in production!!)

change one of the home port of the cluster to the homeport of the other interface. (e.g. two times e0d)

revert the lif to its home port

change the role of the port to whatever you need.(intercluster, data ...)

Re: Need help !!! unable to modify or delete LIF on node of a cluster

Thanks

I have created a new cluster and its working fine now.