Subscribe

Netapp FAS2040 / Volume mount CIFS

In our compagny network most computers are Windows computers and have no issue to mount the Netapp server volumes. And there are also a few Linux computers. We used to mount Netapp volume with CIFS without issue. But since a while we cannot access some directories. We do not know what had happened. We have tried several distributions of Linux and several version of the kernel and samba, We have always the issue; We can mount the volume without error with the following command: "sudo mount -t cifs -o username=user,password=xxxx,sec=ntlm //10.0.10.17/Data MNT", but when we list some directories, we see the error as per the kernel log below.


Examples:

List files and directories of a directory without issue:
  $ ls -lah
  total 291M
  drwxr-xr-x 2 root root 0 Nov 7 10:04 .
  drwxr-xr-x 2 root root 0 Jan 30 12:42 ..
  drwxr-xr-x 2 root root 4.0K Jan 30 14:51 410_Management and reporting
  drwxr-xr-x 2 root root 4.0K Jul 18 2013 413_Field Test Data
  drwxr-xr-x 2 root root 4.0K Feb 2 10:16 420 Product modification requests
  drwxr-xr-x 2 root root 4.0K Nov 19 09:40 430_Misc technical reports
  drwxr-xr-x 2 root root 16K Feb 2 17:28 440_Engineering Notes
  drwxr-xr-x 2 root root 8.0K Feb 2 10:16 450_Misc-thermal simulation
  ….


List files and directory of a directory with the described issue:
  $ ls -lah
  ls: cannot access .: Input/output error
  total 2.5G
  d????????? ? ? ? ? ? .
  drwxr-xr-x 2 root root 0 Jan 19 08:47 ..
  drwxr-xr-x 2 root root 4.0K Dec 11 15:32 AgendaClient
  …
  drwxr-xr-x 2 root root 4.0K Jan 13 2014 XMLGenerator


It happens it is impossible to enter in a directory or list its content. Example:
  $ cd XMLGenerator
  bash: cd: XMLGenerator: Input/output error

 

We have searched for this error on Google. It seems that we are not alone in this situation but we have not found any solution. Could you please help us to solve this issue?


[ 8889.463907] CIFS VFS: Autodisabling the use of server inode numbers on \\10.0.10.17\Data. This server doesn't seem to support them properly. Hardlinks will not be recognized on this mount. Consider mounting with the "noserverino" option to silence this message.
[ 8921.375637] CIFS VFS: RFC1001 size 142 smaller than SMB for mid=58
[ 8921.375643] Bad SMB: : dump of 48 bytes of data at 0xffff8800cd0d7480
[ 8921.375647] 8e000000 424d53ff 00000032 80018800 . . . . \xffffffff S M B 2 . . . . . . .
[ 8921.375651] 00000000 00000000 00000000 12a90040 . . . . . . . . . . . . @ . \xffffffa9 .
[ 8921.375655] 003a0800 5e00020a 02000000 00003800 . . : . . . . ^ . . . . . 8 . .
[ 8921.376018] CIFS VFS: RFC1001 size 142 smaller than SMB for mid=59
[ 8921.376021] Bad SMB: : dump of 48 bytes of data at 0xffff8800cd0d7640
[ 8921.376024] 8e000000 424d53ff 00000032 80018800 . . . . \xffffffff S M B 2 . . . . . . .
[ 8921.376028] 00000000 00000000 00000000 12a90040 . . . . . . . . . . . . @ . \xffffffa9 .
[ 8921.376031] 003b0800 5e00020a 02000000 00003800 . . ; . . . . ^ . . . . . 8 . .
[ 8921.697334] CIFS VFS: RFC1001 size 142 smaller than SMB for mid=61
[ 8921.697339] Bad SMB: : dump of 48 bytes of data at 0xffff8800cd0d79c0
[ 8921.697344] 8e000000 424d53ff 00000032 80018800 . . . . \xffffffff S M B 2 . . . . . . .
[ 8921.697347] 00000000 00000000 00000000 12a90040 . . . . . . . . . . . . @ . \xffffffa9 .
[ 8921.697351] 003d0800 5e00020a 02000000 00003800 . . = . . . . ^ . . . . . 8 . .
[ 8921.697681] CIFS VFS: RFC1001 size 142 smaller than SMB for mid=62
[ 8921.697685] Bad SMB: : dump of 48 bytes of data at 0xffff8800cd0d7b80
[ 8921.697690] 8e000000 424d53ff 00000032 80018800 . . . . \xffffffff S M B 2 . . . . . . .
[ 8921.697694] 00000000 00000000 00000000 12a90040 . . . . . . . . . . . . @ . \xffffffa9 .
[ 8921.697697] 003e0800 5e00020a 02000000 00003800 . . > . . . . ^ . . . . . 8 . .
[ 8921.698115] CIFS VFS: RFC1001 size 142 smaller than SMB for mid=63
[ 8921.698120] Bad SMB: : dump of 48 bytes of data at 0xffff8800cd0d7d40
[ 8921.698124] 8e000000 424d53ff 00000032 80018800 . . . . \xffffffff S M B 2 . . . . . . .
[ 8921.698128] 00000000 00000000 00000000 12a90040 . . . . . . . . . . . . @ . \xffffffa9 .
[ 8921.698132] 003f0800 5e00020a 02000000 00003800 . . ? . . . . ^ . . . . . 8 . .
[ 8929.533584] CIFS VFS: RFC1001 size 142 smaller than SMB for mid=69
[ 8929.533590] Bad SMB: : dump of 48 bytes of data at 0xffff8800cd0d7480
[ 8929.533594] 8e000000 424d53ff 00000032 80018800 . . . . \xffffffff S M B 2 . . . . . . .
[ 8929.533598] 00000000 00000000 00000000 12a90040 . . . . . . . . . . . . @ . \xffffffa9 .
[ 8929.533602] 00450800 5e00020a 02000000 00003800 . . E . . . . ^ . . . . . 8 . .
[ 8929.533980] CIFS VFS: RFC1001 size 142 smaller than SMB for mid=70
[ 8929.533985] Bad SMB: : dump of 48 bytes of data at 0xffff8800cd0d7640
[ 8929.533989] 8e000000 424d53ff 00000032 80018800 . . . . \xffffffff S M B 2 . . . . . . .
[ 8929.533993] 00000000 00000000 00000000 12a90040 . . . . . . . . . . . . @ . \xffffffa9 .
[ 8929.533997] 00460800 5e00020a 02000000 00003800 . . F . . . . ^ . . . . . 8 . .
[ 8929.534363] CIFS VFS: RFC1001 size 142 smaller than SMB for mid=71
[ 8929.534365] Bad SMB: : dump of 48 bytes of data at 0xffff8800cd0d7800
[ 8929.534369] 8e000000 424d53ff 00000032 80018800 . . . . \xffffffff S M B 2 . . . . . . .
[ 8929.534372] 00000000 00000000 00000000 12a90040 . . . . . . . . . . . . @ . \xffffffa9 .
[ 8929.534376] 00470800 5e00020a 02000000 00003800 . . G . . . . ^ . . . . . 8 . .
[ 8931.333945] CIFS VFS: RFC1001 size 142 smaller than SMB for mid=75
[ 8931.333951] Bad SMB: : dump of 48 bytes of data at 0xffff8800cd0d7b80
[ 8931.333955] 8e000000 424d53ff 00000032 80018800 . . . . \xffffffff S M B 2 . . . . . . .
[ 8931.333959] 00000000 00000000 00000000 12a90040 . . . . . . . . . . . . @ . \xffffffa9 .
[ 8931.333963] 004b0800 5e00020a 02000000 00003800 . . K . . . . ^ . . . . . 8 . .
[ 8931.334341] CIFS VFS: RFC1001 size 142 smaller than SMB for mid=76
[ 8931.334345] Bad SMB: : dump of 48 bytes of data at 0xffff8800cd0d79c0
[ 8931.334350] 8e000000 424d53ff 00000032 80018800 . . . . \xffffffff S M B 2 . . . . . . .
[ 8931.334353] 00000000 00000000 00000000 12a90040 . . . . . . . . . . . . @ . \xffffffa9 .
[ 8931.334357] 004c0800 5e00020a 02000000 00003800 . . L . . . . ^ . . . . . 8 . .
[ 8931.334740] CIFS VFS: RFC1001 size 142 smaller than SMB for mid=77
[ 8931.334744] Bad SMB: : dump of 48 bytes of data at 0xffff8800cd0d7800
[ 8931.334749] 8e000000 424d53ff 00000032 80018800 . . . . \xffffffff S M B 2 . . . . . . .
[ 8931.334752] 00000000 00000000 00000000 12a90040 . . . . . . . . . . . . @ . \xffffffa9 .
[ 8931.334756] 004d0800 5e00020a 02000000 00003800 . . M . . . . ^ . . . . . 8 . .

Re: Netapp FAS2040 / Volume mount CIFS

First, you tagged Clustered onTap, based on a 2040 you are running, i assume this is 7-mode.

 

What is the qtree security on your volume.

 

I assume you are doing mixed mounts, since you want to add access from both windows and linux.  If thats the case, my recommendation for net new is either adopt RFC2307 and run NTFS qtree

 

Show me output of

 

qtree security /vol/volname/  and if qtree exists /qtreename

Re: Netapp FAS2040 / Volume mount CIFS

Hi,

 

Thank you for your comment.

 

As per NetApp OnCommand System Manager, we have:

Model: FAS2040

Version: NetApp Release 8.1.4P4 7-Mode

 

All our volumes have "ntfs security style and oplocks are enabled"

 

fileserver4> qtree
qtree: This command is deprecated; using qtree status.
Volume   Tree     Style Oplocks  Status
-------- -------- ----- -------- ---------
vol1              unix  enabled  normal
vol_ServiceProjects          ntfs  enabled  normal
vol_ServiceProjects ServiceProjects ntfs  enabled  normal
vol_SalesProjects          ntfs  enabled  normal
vol_SalesProjects SalesProjects ntfs  enabled  normal
vol_Data          ntfs  enabled  normal
vol_Data Archive  ntfs  enabled  normal
vol_Data Data     ntfs  enabled  normal
vol_User_Installer          ntfs  enabled  normal
vol_User_Installer InstallerData ntfs  enabled  normal
vol_User_Installer UserData ntfs  enabled  normal
vol_Backup          mixed enabled  normal
vol_Backup Backup   ntfs  enabled  normal
vol_EngineeringProjects          mixed enabled  normal
vol_EngineeringProjects EngineeringProjects ntfs  enabled  normal

 

We tried to enable "Mixed (UNIX and NTFS)" security style but this does not fix our issue with Linux client machines.

 

Re: Netapp FAS2040 / Volume mount CIFS

Forget mixed.. and once you have data in it you should NEVER change the security Style... At least that's my recommendation

 

Do you have a full RFC2307.. If not, you need to have same account in AD as you do in unix machine.. yadd yadda

 

Re: Netapp FAS2040 / Volume mount CIFS

Our company network is primitive and we do not have any domain controller nor active directory. Users and groups have been defined directly on our NetApp. This works fine from all our Windows (XP, Vista, 7 and 8) client computers.