Subscribe
Accepted Solution

New user can't login to HTTP management portal

Hi there.

 

I've stuck with a problem that I don't know how to solve...

 

I'm trying to create another user to manage my cluster, I use this command:

 

 security login create -user-or-group-name someuser -application http -authentication-method password -role admin -is-ns-switch-group no -second-authentication-method none -vserver CLUSTER

 

Where CLUSTER is my cluster management SVM name and someuser is the login I want to create.

It asks for creating a password for someuser, which I did.

 

I then create also ssh access for that same user:

 

security login create -user-or-group-name someuser -application ssh -authentication-method password -role admin -is-ns-switch-group no -second-authentication-method none -vserver CLUSTER

 

 

SSH works without problem.

When I try to login in the HTTP management portal, it keep asking for authentication...

 

Can someone give me some advice on this?

netapp2.jpg

Re: New user can't login to HTTP management portal

Seems like I solved it, just don't understand why...

 

I added the ontapi application to the new user, now it's working:

security login create -user-or-group-name someuser -application ontapi -authentication-method password -role admin -is-ns-switch-group no -second-authentication-method none -vserver CLUSTER

Can someone explain this to me? Why the HTTP management portal user need ontapi access?

 

Re: New user can't login to HTTP management portal

Hi @ericknoleto,

 

ONTAPI is requires because System Manager uses ZAPI calls to communicate with the storage, please see this KB.

 

Lorenzo

Re: New user can't login to HTTP management portal

Thanks Lorenzo!