Subscribe

OCPM 7 RC1, RedHat FAILURE: netapp-application-server package installed, but in corrupt state.

I have errors when installing OnCommand Performance Manager 7.1 on Redhat 7

 

The pre installation script output

 

./pre_install_check.sh

Checking system...

Console output logged to pre_install_check.log

Checking for RHEL repository...
Passed.

Checking for the Red Hat Third Party Oracle Java repository...
Passed.

Checking for MySQL 5.6 Community repository...
Passed.

Checking for the Red Hat Extra Packages for Enterprise Linux (EPEL) repository...
Passed.

Checking system for noexec permission against /tmp partition...
Passed.

No issues were detected.

To proceed with upgrading enter the following command as root,
in the current directory:
# ./upgrade.sh

 

 

 

 

an then the installation

 

 

yum install *.rpm
Geladene Plugins: search-disabled-repos
netapp-application-server-1.4.0-2016.06.J2265.x86_64.rpm wird untersucht: netapp-application-server-1.4.0-2016.06.J2265.x86_64
netapp-application-server-1.4.0-2016.06.J2265.x86_64.rpm: aktualisiert installierte Pakete nicht.
netapp-opm-7.0.0.2015.12.N160626.1151.x86_64.rpm wird untersucht: netapp-opm-7.0.0-2015.12.N160626.1151.x86_64
netapp-opm-7.0.0.2015.12.N160626.1151.x86_64.rpm wird zum Installieren markiert
netapp-platform-base-1.4.0-2016.06.J2265.el7.x86_64.rpm wird untersucht: netapp-platform-base-1.4.0-2016.06.J2265.x86_64
netapp-platform-base-1.4.0-2016.06.J2265.el7.x86_64.rpm wird zum Installieren markiert
ocf-server-1.4.0-2016.06.J2263.x86_64.rpm wird untersucht: 1:ocf-server-1.4.0-2016.06.J2263.x86_64
ocf-server-1.4.0-2016.06.J2263.x86_64.rpm wird zum Installieren markiert
ocie-au-1.4.0-2016.02.J2279.x86_64.rpm wird untersucht: ocie-au-1.4.0-2016.02.J2279.x86_64
ocie-au-1.4.0-2016.02.J2279.x86_64.rpm wird zum Installieren markiert
ocie-server-1.4.0-2016.02.J2279.x86_64.rpm wird untersucht: ocie-server-1.4.0-2016.02.J2279.x86_64
ocie-server-1.4.0-2016.02.J2279.x86_64.rpm wird zum Installieren markiert
ocie-serverbase-1.4.0-2016.06.J2265.x86_64.rpm wird untersucht: ocie-serverbase-1.4.0-2016.06.J2265.x86_64
ocie-serverbase-1.4.0-2016.06.J2265.x86_64.rpm: aktualisiert installierte Pakete nicht.
Abhängigkeiten werden aufgelöst
--> Transaktionsprüfung wird ausgeführt
---> Paket netapp-opm.x86_64 0:7.0.0-2015.12.N160626.1151 markiert, um installiert zu werden
---> Paket netapp-platform-base.x86_64 0:1.4.0-2016.06.J2265 markiert, um installiert zu werden
---> Paket ocf-server.x86_64 1:1.4.0-2016.06.J2263 markiert, um installiert zu werden
---> Paket ocie-au.x86_64 0:1.4.0-2016.02.J2279 markiert, um installiert zu werden
---> Paket ocie-server.x86_64 0:1.4.0-2016.02.J2279 markiert, um installiert zu werden
--> Abhängigkeitsauflösung beendet

Abhängigkeiten aufgelöst

===========================================================================================================================================================================
 Package                            Arch                 Version                                  Paketquelle                                                        Größe
===========================================================================================================================================================================
Installieren:
 netapp-opm                         x86_64               7.0.0-2015.12.N160626.1151               /netapp-opm-7.0.0.2015.12.N160626.1151.x86_64                       92 M
 netapp-platform-base               x86_64               1.4.0-2016.06.J2265                      /netapp-platform-base-1.4.0-2016.06.J2265.el7.x86_64               3.2 M
 ocf-server                         x86_64               1:1.4.0-2016.06.J2263                    /ocf-server-1.4.0-2016.06.J2263.x86_64                             109 M
 ocie-au                            x86_64               1.4.0-2016.02.J2279                      /ocie-au-1.4.0-2016.02.J2279.x86_64                                 26 M
 ocie-server                        x86_64               1.4.0-2016.02.J2279                      /ocie-server-1.4.0-2016.02.J2279.x86_64                             15 M

Transaktionsübersicht
===========================================================================================================================================================================
Installieren  5 Pakete

Gesamtgröße: 245 M
Installationsgröße: 245 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction

FAILURE: netapp-application-server package installed, but in corrupt state.
    Correct the netapp-application-server package and try again.

Fehler: %pre(netapp-platform-base-1.4.0-2016.06.J2265.x86_64) Scriptlet fehlgeschlagen, Beenden-Status 255
Error in PREIN scriptlet in rpm package netapp-platform-base-1.4.0-2016.06.J2265.x86_64
Fehler: netapp-platform-base-1.4.0-2016.06.J2265.x86_64: installieren fehlgeschlagen

netapp-platform-base package is not installed. Install netapp-platform-base package and try again

Fehler: %pre(ocie-server-0:1.4.0-2016.02.J2279.x86_64) Scriptlet fehlgeschlagen, Beenden-Status 255
Error in PREIN scriptlet in rpm package ocie-server-1.4.0-2016.02.J2279.x86_64
Fehler: ocie-server-0:1.4.0-2016.02.J2279.x86_64: installieren fehlgeschlagen

ocie-server package is not installed. Install ocie-server package and try again.

Fehler: %pre(ocie-au-0:1.4.0-2016.02.J2279.x86_64) Scriptlet fehlgeschlagen, Beenden-Status 255
Error in PREIN scriptlet in rpm package ocie-au-1.4.0-2016.02.J2279.x86_64
Fehler: ocie-au-0:1.4.0-2016.02.J2279.x86_64: installieren fehlgeschlagen
ocie-au package not installed. Install ocie-au package and try again.
Fehler: %pre(ocf-server-1:1.4.0-2016.06.J2263.x86_64) Scriptlet fehlgeschlagen, Beenden-Status 255
Error in PREIN scriptlet in rpm package 1:ocf-server-1.4.0-2016.06.J2263.x86_64
Fehler: ocf-server-1:1.4.0-2016.06.J2263.x86_64: installieren fehlgeschlagen


FAILURE: ocf-server package is not installed. Install ocf-server package and try again.
         Installer will exit now.


Fehler: %pre(netapp-opm-7.0.0-2015.12.N160626.1151.x86_64) Scriptlet fehlgeschlagen, Beenden-Status 255
Error in PREIN scriptlet in rpm package netapp-opm-7.0.0-2015.12.N160626.1151.x86_64
  Überprüfung läuft: ocie-au-1.4.0-2016.02.J2279.x86_64                                                                                                                1/5
  Überprüfung läuft: ocie-server-1.4.0-2016.02.J2279.x86_64                                                                                                            2/5
  Überprüfung läuft: 1:ocf-server-1.4.0-2016.06.J2263.x86_64                                                                                                           3/5
  Überprüfung läuft: netapp-opm-7.0.0-2015.12.N160626.1151.x86_64                                                                                                      4/5
  Überprüfung läuft: netapp-platform-base-1.4.0-2016.06.J2265.x86_64                                                                                                   5/5

Fehlgeschlagen:
  netapp-opm.x86_64 0:7.0.0-2015.12.N160626.1151            netapp-platform-base.x86_64 0:1.4.0-2016.06.J2265            ocf-server.x86_64 1:1.4.0-2016.06.J2263           
  ocie-au.x86_64 0:1.4.0-2016.02.J2279                      ocie-server.x86_64 0:1.4.0-2016.02.J2279                    

Komplett

 

 

 

Thank you for your help!

 

 

Re: OCPM 7 RC1, RedHat FAILURE: netapp-application-server package installed, but in corrupt state.

Hi,

 

Try the root credentials to install.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: OCPM 7 RC1, RedHat FAILURE: netapp-application-server package installed, but in corrupt state.

Already installing with root credentials. Fresh RHEL Enterprise install, 7.2..

Re: OCPM 7 RC1, RedHat FAILURE: netapp-application-server package installed, but in corrupt state.

any update/fix about this issue ?

 

 

Rezk Mekhael