Subscribe

ONTAP Select - configuration_failed InternalErr: Failed to read host version

Hi all,

 

I have been trying to deploy Ontap select on an ESXi 6.0 and I cannot configure the host after is has been authenticated:

 

(ONTAPdeploy) host show-all
+--------------------------+---------------+------+
| Host                     | Status        | Type |
+--------------------------+---------------+------+
| 192.168.0.123            | authenticated | ESX  |
+--------------------------+---------------+------+
(ONTAPdeploy)

next the configuration step:

 

 

(ONTAPdeploy) host configure --host-id 192.168.0.123 --location RZ1 --storage-pool localstorage --internal-network Peer2Peer --management-network VMNet01 --data-network VMNet01
Host configuration updated for host: 192.168.0.123
(ONTAPdeploy) host show-all
+--------------------------+----------------------+------+
| Host                     | Status               | Type |
+--------------------------+----------------------+------+
| 192.168.0.123            | configuration_failed | ESX  |
+--------------------------+----------------------+------+
(ONTAPdeploy)

 

 

Eventlog:

 

(ONTAPdeploy) event show-all
+----------+-----------------------+-------+------+-----------------------------------------------------------------------+----------------------------+
| category | type                  | level | code | detail                                                                | time                       |
+----------+-----------------------+-------+------+-----------------------------------------------------------------------+----------------------------+
| host     | HostConfigureFailed   | Error |  215 | InternalErr: Failed to read host version                              | 2016.08.03 12:17:29.181854 |
| host     | HostConfigureAccepted | Info  |  208 | Add configuration request for host 192.168.0.123 accepted.            | 2016.08.03 12:17:19.382275 |
| host     | HostAddSuccessful     | Info  |  207 | Host 192.168.0.123 added successfully.                                | 2016.08.03 10:55:30.275210 |
| host     | HostAddAccepted       | Info  |  206 | Add request for host 192.168.0.123 accepted.                          | 2016.08.03 10:55:27.050425 |
+----------+-----------------------+-------+------+-----------------------------------------------------------------------+----------------------------+
(ONTAPdeploy)

 

 

Here is the debug log file /opt/netapp/log/sdotadmin_server.log

 

2016-08-03 13:42:02,882|DEBUG Jsonifing http://localhost:8000/api/v1/hosts
2016-08-03 13:42:02,882|DEBUG Function Arguments: []
2016-08-03 13:42:02,883|DEBUG Body parameter 'None' not in function arguments
2016-08-03 13:42:02,884|DEBUG Getting data and status code
2016-08-03 13:42:02,884|DEBUG Got data and status code (200)
2016-08-03 13:42:02,906|DEBUG Getting data and status code
2016-08-03 13:42:02,906|DEBUG Got data and status code (200)
2016-08-03 13:43:10,162|DEBUG http://localhost:8000/api/v1/hosts/192.168.0.123/configuration validating schema...
2016-08-03 13:43:10,184|DEBUG http://localhost:8000/api/v1/hosts/192.168.0.123/configuration validating parameters...
2016-08-03 13:43:10,185|DEBUG Jsonifing http://localhost:8000/api/v1/hosts/192.168.0.123/configuration
2016-08-03 13:43:10,185|DEBUG Function Arguments: ['host_id', 'new_configuration']
2016-08-03 13:43:10,185|DEBUG Body parameter 'new_configuration' in function arguments
2016-08-03 13:43:10,200|DEBUG Getting data and status code
2016-08-03 13:43:10,200|DEBUG Got data and status code (202)
2016-08-03 13:43:10,234|DEBUG Getting data and status code
2016-08-03 13:43:10,234|DEBUG Got data and status code (202)
2016-08-03 13:43:12,962|DEBUG Jsonifing http://localhost:8000/api/v1/hosts
2016-08-03 13:43:12,962|DEBUG Function Arguments: []
2016-08-03 13:43:12,962|DEBUG Body parameter 'None' not in function arguments
2016-08-03 13:43:12,963|DEBUG Getting data and status code
2016-08-03 13:43:12,963|DEBUG Got data and status code (200)
2016-08-03 13:43:12,996|DEBUG Getting data and status code
2016-08-03 13:43:12,997|DEBUG Got data and status code (200)
2016-08-03 13:43:20,556|DEBUG response body: {"available_datastores":[{"allocation":980,"capacity":1710848,"name":"localstorage","pdisks":["Local IBM Disk (naa.600605b005783e801f3222af848feec6)"],"status":"Online"}],"available_networks":[{"name":"VMNet10","vlanid":"1","vswitch":"vSwitch0"},{"name":"VMNet01","vlanid":"0","vswitch":"vSwitch0"},{"name":"Peer2Peer","vlanid":"0","vswitch":"vSwitch1"}],"available_pdisks":[{"adapter_name":"vmhba3","description":"Local IBM Disk ","name":"naa.600605b005783e801f3222af848feec6","total_diskspace":1710888,"used_by":"localstorage"},{"adapter_name":"vmhba3","description":"Local IBM Disk ","name":"naa.600605b005783e801f32224e7ec982e5","total_diskspace":46730,"used_by":"---"},{"adapter_name":null,"description":"Local USB Direct-Access ","name":"mpx.vmhba32:C0:T0:L0","total_diskspace":1911,"used_by":"---"}],"available_vms":[],"esxadmin_status":{"ESX_license":"VMware vSphere 6 Enterprise","SDK_version":"6.0.0","host":"192.168.0.123","server":"192.168.0.125","user":"DOMAIN\\VMware-Service"},"host_configuration":{"host_hardware_config":{"cores_in_use":1,"cpu_mhz":"2499","mem_usage":"2761","memory_size":98276,"num_cpu_cores":"6","num_hbas":"8","num_nics":"7","processor_model":"Intel(R) Xeon(R) CPU E5-2640 0 @ 2.50GHz","product_ver":"VMware ESXi 6.0.0","vendor":"IBM"},"hypervisor_info":{"api_version":"6.0","bios_release_date":"2016-04-28T00:00:00Z","bios_version":"-[D7E152CUS-2.11]-","firewall_defaults_in":"blocked","firewall_defaults_out":"blocked","hyperthreading":"active","hypervisor":"VMware ESXi 6.0.0 Build-3825889","model":"IBM System x3550 M4 Server -[7914F2G]-","power_mgmt_policy":"High Performance","power_mgmt_technology":"ACPI P-states, ACPI C-states","reboot_required":"No","uuid":"957aae0e-9ef7-3a76-987a-81b8e6bfa598"},"network_adapters":[{"associated_vswitch":"vSwitch0","enabled":true,"mac":"6c:ae:8b:62:bf:f2","name":"vmnic0","speed":"100","vendor":"Intel Corporation I350 Gigabit Network Connection"},{"associated_vswitch":"vSwitch0","enabled":false,"mac":"6c:ae:8b:62:bf:f3","name":"vmnic1","speed":"Unset","vendor":"Intel Corporation I350 Gigabit Network Connection"},{"associated_vswitch":"None","enabled":false,"mac":"6c:ae:8b:62:bf:f4","name":"vmnic2","speed":"Unset","vendor":"Intel Corporation I350 Gigabit Network Connection"},{"associated_vswitch":"None","enabled":false,"mac":"6c:ae:8b:62:bf:f5","name":"vmnic3","speed":"Unset","vendor":"Intel Corporation I350 Gigabit Network Connection"},{"associated_vswitch":"vSwitch1","enabled":false,"mac":"a0:36:9f:87:44:0c","name":"vmnic4","speed":"Unset","vendor":"Intel Corporation Ethernet Controller 10 Gigabit X540-AT2"},{"associated_vswitch":"vSwitch1","enabled":true,"mac":"a0:36:9f:87:44:0e","name":"vmnic5","speed":"10000","vendor":"Intel Corporation Ethernet Controller 10 Gigabit X540-AT2"},{"associated_vswitch":"None","enabled":true,"mac":"6e:ae:8b:62:bf:f1","name":"vusb0","speed":"10","vendor":"Intel Corporation Ethernet Controller 10 Gigabit X540-AT2"}],"storage_adapters":[{"description":"(0000:00:1f.2) Patsburg 6 Port SATA AHCI Controller","logical_name":"vmhba0","product":"Patsburg 6 Port SATA AHCI Controller"},{"description":"(0000:1b:00.0) MegaRAID SAS Fusion Controller","logical_name":"vmhba3","product":"MegaRAID SAS Fusion Controller"},{"description":"(N\/A) USB Storage Controller","logical_name":"vmhba32","product":"USB Storage Controller"},{"description":"(0000:00:1f.2) Patsburg 6 Port SATA AHCI Controller","logical_name":"vmhba33","product":"Patsburg 6 Port SATA AHCI Controller"},{"description":"(0000:00:1f.2) Patsburg 6 Port SATA AHCI Controller","logical_name":"vmhba34","product":"Patsburg 6 Port SATA AHCI Controller"},{"description":"(0000:00:1f.2) Patsburg 6 Port SATA AHCI Controller","logical_name":"vmhba35","product":"Patsburg 6 Port SATA AHCI Controller"},{"description":"(0000:00:1f.2) Patsburg 6 Port SATA AHCI Controller","logical_name":"vmhba36","product":"Patsburg 6 Port SATA AHCI Controller"},{"description":"(0000:00:1f.2) Patsburg 6 Port SATA AHCI Controller","logical_name":"vmhba37","product":"Patsburg 6 Port SATA AHCI Controller"}],"vswitch_config":[{"associated_adapter":["vmnic1","vmnic0"],"available_ports":2418,"mtu":"1500","name":"vSwitch0","portgroups":["VMNet10","VMNet01","vMotion","Management Network"],"total_ports":2432},{"associated_adapter":["vmnic5","vmnic4"],"available_ports":2418,"mtu":"9000","name":"vSwitch1","portgroups":["Peer2Peer"],"total_ports":2432}]}}
2016-08-03 13:43:20,557|ERROR |Host.py|345:verify_hypervisor_configuration| Error: [10] InternalErr: Failed to read host version
2016-08-03 13:43:20,557|ERROR |Host.py|545:update_configuration| Update host configuration failed
2016-08-03 13:43:20,559|ERROR |host_tasks.py|40:update_host_configuration| InternalErr: Failed to read host version
2016-08-03 13:43:22,006|DEBUG Jsonifing http://localhost:8000/api/v1/hosts
2016-08-03 13:43:22,006|DEBUG Function Arguments: []
2016-08-03 13:43:22,007|DEBUG Body parameter 'None' not in function arguments
2016-08-03 13:43:22,007|DEBUG Getting data and status code
2016-08-03 13:43:22,007|DEBUG Got data and status code (200)
2016-08-03 13:43:22,028|DEBUG Getting data and status code
2016-08-03 13:43:22,028|DEBUG Got data and status code (200)

In the log file you can see "Error: [10] InternalErr: Failed to read host version" but in the line above you can see: hypervisor":"VMware ESXi 6.0.0 Build-3825889"

 

 

Any Ideas?

 

Thanks in advance.

Re: ONTAP Select - configuration_failed InternalErr: Failed to read host version

Hi 

  Thank you for reaching out with the issue that you were having, the engineering team investigate it and determined that you ran into a bug in the code. (thank you for suppling the needed log to triage the issue)

   We have opened a bug report and will get this address for the next release.  

   Unfortunaltely there is no workaround for this issue. 

   

regards

Rick

Re: ONTAP Select - configuration_failed InternalErr: Failed to read host version

Hi,

 

 

Thanks for your reply.

 

Is this bug hardware or vsphere version specific?

 

 

How often do you release a new version of ONTAP select? 

 

I just wanted to test if ONTAP select runs on hardware that does not fully meet the requirements (e.g. CPU)

 

regards

Jagenau

 

Re: ONTAP Select - configuration_failed InternalErr: Failed to read host version

This Bug seems to be fixed in 9.0RC2