Community

Subscribe
Highlighted
Accepted Solution

Perfstat hanging

Having some problems running perfstat7 from Windows. It connects fine to filer and runs prestats but just hangs when doing poststats.

Tried excluding local server data, config data and even killing processes after 10 seconds ("-C 10").

I can see its waiting long time for the "netstat" and "cifs sessions" commands and tried excluding them but then it just hangs anyway.

Any ideas on how to make Perfstat finish?

Just interested in the performance data for troubleshooting.

-Carsten

Re: Perfstat hanging

I have the same problem. Did you find a solution for it?

-Fredrik

Re: Perfstat hanging

Seems like there's a problem with Windows 2008 and the SSH/plink setup.

Got it working with good old Windows XP and RSH.

Re: Perfstat hanging

You can install XP Mode on your Windows 7 machine and run the Perfstat using plink and RSH from the XP VM.

Re: Perfstat hanging

[ Edited ]

This is a plink issue. Try an older version (v0.60):

http://netapp.nunonet.com/supporttool/plink.exe

or use "NetApp Support Tool" to get perfstats:

http://mysupport.netapp.com/NOW/download/tools/gui_ntap_support/

Re: Perfstat hanging

The plink linked above fixed this issue for me.

Re: Perfstat hanging

Had problems with all of the above.  Finally able to get plink working by downloading the latest daily refresh.  Goto putty home page, then downloads then scroll to the bottom of the page and pick up the latest plink.

Re: Perfstat hanging

The older version of plink worked for me - thanks for the advice.

Re: Perfstat hanging

Thanks almeida, your hint solved this for me. The old version 0.60 worked fine, as did the latest daily as suggested by papadopoulosa below.

Re: Perfstat hanging

Started using the unofficial NetApp support tool, this has worked everytime so far.

https://communities.netapp.com/docs/DOC-16209