Subscribe

Quota on LUN

Hello,

 

I have an old FAS2240 in 7-mode 8.1.4P8

I make quota on differents LUNs with hard limit. But when the limit is reached the LUN go to "Offline".

 

It is possible to disable this feature ? The LUN must be always online even if it is full.

 

Thanks for your help

 

Regards

Re: Quota on LUN

Hello,

 

It sounds like you're just referring to the LUN size here vs. the other kind of "quotas" available in ONTAP?  Anyway, ONTAP takes your LUN offline when it fills up to protect data integrity.  Initiators might do unpredictable things to the data if no more space is available and the "safest" course of action for ONTAP to take is to take the disk offline.  This is a couple of years old, but the concepts still apply:

 

https://library.netapp.com/ecmdocs/ECMP1368525/html/GUID-0BE3AF1D-3668-465B-BD72-38A5B2479476.html

 

Hope that helps,

 

Chris

Re: Quota on LUN

Hi there! 

 

It sounds like your LUN has gone offline because the volume containing it has become full. This usually happens because of snapshots being taken of the LUN. The default behaviour is to retain all data and snapshots, and take the LUN offline, but you have a couple of options to prevent this. 

 

There are options to turn off snapshots, automatically grow volumes (vol options autosize) or automatically delete snapshots 

 

Hope this helps!

Re: Quota on LUN

Hi,

 

The LUN goes offline because the quota is reached. My volume and aggregate have free space. No snapshots enables.

I found the solution, the space_alloc option is perfect for my need.

 

Thanks

 

Regards

Re: Quota on LUN

Do you know why your system has a quota on a volume containing a LUN? This is not something we would normally suggest.