Subscribe

S500 - 50% of storage reserved for snapshots, but no volumes have snapshots active, or any snapshots stored

Folks,

This is my first forum post - I am a lost S500 user coming back to the fold.

To my immense surprise, I was unable to resize a LUN today because I'm out of free space. Storevault manager GUI showed lots of free space, so I was confused. I rebooted, and when it came back up 50% of my space was allocated to snapshots.

I went around deleting all the snapshots I could find, disabling all snapshotting, and the net effect was almost nil. Can anyone help me make sense of this?


netapp> snap list
Volume vol0
working...

%/used       %/total  date          name
----------  ----------  ------------  --------
1% ( 1%)    0% ( 0%)  Jan 25 20:00  hourly.0      
1% ( 0%)    0% ( 0%)  Jan 25 16:00  hourly.1      
1% ( 0%)    0% ( 0%)  Jan 25 12:00  hourly.2      
1% ( 0%)    0% ( 0%)  Jan 25 08:00  hourly.3      
1% ( 0%)    0% ( 0%)  Jan 25 00:00  nightly.0     
1% ( 0%)    0% ( 0%)  Jan 24 20:00  hourly.4      
1% ( 0%)    0% ( 0%)  Jan 24 16:00  hourly.5      
1% ( 0%)    0% ( 0%)  Jan 24 00:00  nightly.1     
5% ( 4%)    0% ( 0%)  Jan 10 18:18  CTOVol0Snapshot


netapp> snap reserve
Volume vol0: current snapshot reserve is 20% or 74011840 k-bytes.
Volume shares: current snapshot reserve is 0% or 0 k-bytes.
Volume exports: current snapshot reserve is 0% or 0 k-bytes.
Volume mysql: current snapshot reserve is 0% or 0 k-bytes.
Volume SERVER: current snapshot reserve is 0% or 0 k-bytes.
Volume TIMEMACHINE: current snapshot reserve is 0% or 0 k-bytes.
Volume FAXARCHIVE: current snapshot reserve is 0% or 0 k-bytes.
Volume ESXIbackend: current snapshot reserve is 0% or 0 k-bytes.


netapp> df
Filesystem              kbytes       used      avail capacity  Mounted on
/vol/vol0/           296047372    3762236   26132380      91%  /vol/vol0/
/vol/vol0/.snapshot   74011840     181892   73829948       0%  /vol/vol0/.snapshot
/vol/shares/        1597113632   34717652   26132380      98%  /vol/shares/
/vol/shares/.snapshot          0          0          0     ---%  /vol/shares/.snapshot
/vol/exports/       1597113632   85618596   26132380      98%  /vol/exports/
/vol/exports/.snapshot          0          0          0     ---%  /vol/exports/.snapshot
/vol/mysql/           10590064   10585108       4956     100%  /vol/mysql/
/vol/mysql/.snapshot          0          0          0     ---%  /vol/mysql/.snapshot
/vol/SERVER/         525331456  525331456          0     100%  /vol/SERVER/
/vol/SERVER/.snapshot          0          0          0     ---%  /vol/SERVER/.snapshot
/vol/TIMEMACHINE/   1042490332  105098304  937392028      10%  /vol/TIMEMACHINE/
/vol/TIMEMACHINE/.snapshot          0          0          0     ---%  /vol/TIMEMACHINE/.snapshot
/vol/FAXARCHIVE/     210210112  210132904      77208     100%  /vol/FAXARCHIVE/
/vol/FAXARCHIVE/.snapshot          0          0          0     ---%  /vol/FAXARCHIVE/.snapshot
/vol/ESXIbackend/     10508084   10508084          0     100%  /vol/ESXIbackend/
/vol/ESXIbackend/.snapshot          0          0          0     ---%  /vol/ESXIbackend/.snapshot
netapp>

Thanks in advance for any assistance/tips etc, I'm very new to ontap commandline but tried to do my homework!

-Darren

Re: S500 - 50% of storage reserved for snapshots, but no volumes have snapshots active, or any snapshots stored

Hi & welcome to the forums!

I am not quite sure whether S-series works in exactly the same way as 'normal' filers, but I reckon you got stung by fractional reserve.

See Chris' blog post for thorough explanation:

http://communities.netapp.com/groups/chris-kranz-hardware-pro/blog/2009/03/05/fractional-reservation--lun-overwrite

Regards,
Radek

Re: S500 - 50% of storage reserved for snapshots, but no volumes have snapshots active, or any snapshots stored

Thanks for the welcome Radek, and for taking the time to reply. I must confess I'm not sure how the fractional reservation explanation you reference might have come into play here, but that may just be my inexperience.

In the end, I deleted one single LUN (the FAXARCHIVE one) and kaboom, all of the snapshot reserve was released and it's back down to a mere 2GB right now.

Perhaps there was not enough free space left on the appliance for it to actually completely process the deletion of all the snapshots I had cleaned up?

-Darren

Re: S500 - 50% of storage reserved for snapshots, but no volumes have snapshots active, or any snapshots stored

OK, don't confuse snapshot reserve with fractional reserve, as these are two different things!

[Assuming S boxes CLI works in the same way]

If you type this command:

vol options volname

then each volume with default settings will result with this
fractional_reserve=100

This means that if you have a LUN in that volume, ONTAP will try to reserve space within the volume for at least one snapshot, assuming the worst case scenario, i.e. 100% change, i.e. 100% extra space needed. So translating that into plain English:

2GB volume with 1GB LUN in it will be full, as soon as there is at least one snapshot in that volume, no matter what the actual size of that snapshot is.

The current best practice is to set fractional reserve to 0 (when bearing in mind all additional caveats about volume autosize, snap autodelete, etc.)

Regards,
Radek