Subscribe

SMSQL snapshot clone fails to mount - DBCC fails

Hello everyone,

I have been banging my head on this one for a few days and I'm _really_ hoping someone else has run into this problem and has some suggestions:

I have several VMs running Windows 2003 and MSSQL 2005 (all on the same ESXi 4 mother ship).  All of LUNs for the databases are under the same volume.  They are all running SnapDrive version 6.3.0.4813. And all of them, except for one, during the verify phase of the backup are able to mount the snapshot and run DBCC verify against the database (and the clone).  When I remove the -ver (verify) options the backup job completes successfully and both the SnapVault and SnapMirror relationships are updated. 

The only clue I have to the problem is in the *** VERIFY DATABASE AFTER BACKUP section of the backup report.

[11:03:21.578]  Mount point directory [C:\Program Files\NetApp\SnapManager for SQL Server\SnapMgrMountPoint]

[11:03:21.578]  Snapshot will be mounted on subdirectory [MPDisk001]

[11:06:34.131]  [SnapDrive Error]: Failed to mount backup sqlsnap__xxxxxsql01_03-13-2012_11.02.08__daily. Reasons Failed to mount disk (Disk Id  <6000C291-6f36-eaee-c33b-991af3a498c1>) in Backup <3f4cbf7e-4352-45de-a1b3-96ba745fb30b>. Server Error: <Failed to create a  VirtualDeviceConfigSpec. Cannot attach the requested disk.>. .(SnapDrive Error Code: 0xc0041057).

VirtualDeviceConfigSpec is a VMWare 'thing' and seems to be used to make changes, such as adding a disk, to running VMs.  Besides that I don't know much about it. 

Thanks,

Jim

Re: SMSQL snapshot clone fails to mount - DBCC fails

This sounds like it  maybe a support related question.  We have external and internal subject matter experts in the NetApp Support Community answering questions about SnapX products and software.   If you have a NOW login you can ask the question there.

Mike