Subscribe

SnapDrive Error: SME verification failed

SnapManager for Exchange verifications failing with following error:

Windows Event Log

*****BACKUP DETAIL SUMMARY*****
Backup group set #1:
Backup SG [First Storage Group] Error: Failed to verify physical integrity of the databases.


*****BACKUP RESULT SUMMARY*****

Backup group set #1:
Backup SG [First Storage Group]: Backup OK, verification failed

Backup failed.[SnapDrive Error]: Failed to create disk in virtual machine, Failed to Map virtual disk: Object reference not set to an instance of an object..

SME Log

[12:01:10.754]  BackupVerification Job of JobID 2654 starts to run on server Vmmail2.

[12:01:10.785]  The destination volume of the source Logical Disk Q FlexClone State is Success and SnapMirror State is Unknown.

[12:01:17.785]  Mounting Snapshot [exchsnap__vmmail2_08-13-2010_12.00.38] for LUN Q created from Computer VMMAIL2

[12:01:17.801]  Mount point directory [C:\Program Files\NetApp\SnapManager for Exchange\SnapMgrMountPoint]

[12:01:19.426]  Snapshot will be mounted on subdirectory [MPDisk013]

[12:15:23.614]  [SnapDrive Error]: Failed to create disk in virtual machine, Failed to Map virtual disk: Object reference not set to an instance of an object..  (SnapDrive Error Code: 0xc00403e3) [12:15:23.614]  SnapDrive failed to mount the snapshot.

[12:15:23.614]  [SnapDrive Error]: Failed to create disk in virtual machine, Failed to Map virtual disk: Object reference not set to an instance of an object..

[12:15:23.614]  Unable to mount snapshot, abort verification.

[12:15:23.614]  [SnapDrive Error]: Failed to create disk in virtual machine, Failed to Map virtual disk: Object reference not set to an instance of an object..

[12:15:23.614]  BackupVerification Job of JobID=2654 is finished with status Failed.

[12:15:24.098]  [SnapDrive Error]: Failed to create disk in virtual machine, Failed to Map virtual disk: Object reference not set to an instance of an object..

[12:15:24.192]  [SnapDrive Error]: Failed to create disk in virtual machine, Failed to Map virtual disk: Object reference not set to an instance of an object..

[12:15:26.926]  Error code: 0xc00403e3, LUN: Q:\ [12:15:26.926]  An autosupport message is sent on failure to the storage system of LUN [Q:\].  [12:15:26.926]  ***BACKUP VERIFICATION STATUS: First Storage Group

[12:15:26.926]  Failed to verify physical integrity of the databases.

Any help is appreciated as my disk is filling up as logs are not being truncated.

Thanks!

Re: SnapDrive Error: SME verification failed

From the error it seems it's not able to mount the backup/snapshot.

Can you provide the details about the environment, storage, application, server etc ?

Re: SnapDrive Error: SME verification failed

I have two exchange servers 2003 both with Snapdrive 6.1 and SME 5.0. Storage is NetApp FAS 2020 on DS14MK4 Shelves running on FC. Exchange Database and Logs  are on two physical RDMs. Oddly enough one of the exchange servers works just fine. Something seems odd in the igroups though - I've attached a screen shot. The VMware HP igroup was manually created but the via RPC ones are created automatically by Snapdrive. VMMAIL2 does not seem to have an igroup to f8:8f.  Not sure if that has anything to do with it.

Thanks,

Re: SnapDrive Error: SME verification failed

Yes, it looks more a SnapDrive issue rather than SME.

To concur you can manually try to connect the snapshot as a disk from LUN Q from VMMAIL2.

[12:01:17.785]  Mounting Snapshot [exchsnap__vmmail2_08-13-2010_12.00.38] for LUN Q created from Computer VMMAIL2

And let us know the Log in event.

Re: SnapDrive Error: SME verification failed

Manually attempting to connect results in attached.  Not much help there. I did select all igroups, however so that doesn't seem to be the issue.

Re: SnapDrive Error: SME verification failed

Okay, this is then a SnapDrive issue. Are these basic/dynamic disc in windows ?

Also, from the igroup thing, which all WWPN you selected while trying to connect to the Snapshot ?

From the Igroup list, it seems you only have 1 WWPN logged in from that VM. In case you specify SnapDrive some other WWPN to connect to the disk it throws a error thinking it's not connected.

Do check from the VM weather both the WWPN are visible. If not try only select 1 WWPN from the list you have. ( The one shown in the igroup list you attached previously).

You can perform the same thing by manually creating a new disk and see if that works or not ?

And Logs Please !

Re: SnapDrive Error: SME verification failed

I attempted to reinstall SD and now I cannot see the luns in SnapDrive at all.  I can, however, get to the drives in explorer so everything is working but SD.

In troubleshooting why I cannot see the LUNs at all anymore the event viewer shows the following:

Event Type:     Warning
Event Source:     SnapDrive
Event Category:     Generic event
Event ID:     317
Date:          8/20/2010
Time:          4:53:34 AM
User:          N/A
Computer:     VMMAIL2
Description:
Failed to enumerate LUN.
Device path: '\\?\scsi#disk&ven_netapp&prod_lun&rev_7320#4&3a739529&0&000100#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}'
Storage path: '/vol/vmmail2_sg1/vmmail2_sg1/vmmail2_sg1.lun'
SCSI address: (1,0,1,0)
Error code: 0xc00402fa
Error description: A LUN with device path \\?\scsi#disk&ven_netapp&prod_lun&rev_7320#4&3a739529&0&000100#{53f56307-b6bf-11d0-94f2-00a0c91efb8b} and SCSI address (1, 0, 1, 0) is exposed through an unsupported initiator.

Event Type: Warning

Event Source: SnapDrive

Event Category: Generic event

Event ID: 317

Date: 8/20/2010

Time: 4:53:36 AM

User: N/A

Computer: VMMAIL2

Description:

Failed to enumerate LUN.

Device path: '\\?\scsi#disk&ven_netapp&prod_lun&rev_7320#4&3a739529&0&000200#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}'

Storage path: '/vol/vmmail2_logs/vmmail2_logs/vmmail2_logs.lun'

SCSI address: (1,0,2,0)

Error code: 0xc00402fa

Error description: A LUN with device path \\?\scsi#disk&ven_netapp&prod_lun&rev_7320#4&3a739529&0&000200#{53f56307-b6bf-11d0-94f2-00a0c91efb8b} and SCSI address (1, 0, 2, 0) is exposed through an unsupported initiator.

It seems to me that SD cannot see the manually created igroup on the filer. I removed the other SD created igroups which is probably why I can't see the LUNs anymore.

Re: SnapDrive Error: SME verification failed

Hi,

What is the Data ONTAP version out here ?

You are getting a error which looks more to me a old bug ( related to iSCSI environment). But have a look at this KB article : https://now.netapp.com/Knowledgebase/solutionarea.asp?id=kb48300

It's more related to the issue you are facing, but the error is not the same. What you should quickly do is to open a support case.

Also, since you are not able to see the drives using SnapDrive your SMe backup's will fail. Hence, you can manually unmap the LUN's and try connecting the LUN's using SnapDrive. ( As mentioned in the KB Article).

If you want to be extra cautious, simply restart the SD services, and try creating a new Test LUN using SnapDrive and see if that works or not ? If it does, above unmapping/mapping should do the trick.

-Bakshana

Re: SnapDrive Error: SME verification failed

Also, try SnapDrive 6.2P1 as that is fixes lots of issues identified.

Message was edited by: Bakshana Ogra

Re: SnapDrive Error: SME verification failed

required solution

Event Type:        Error

Event Source:    SnapDrive

Event Category:                LUN event

Event ID:              1108

Date:                     11/19/2010

Time:                     5:37:04 AM

User:                     N/A

Computer:          xxxxxxxxxxxxxxxxx

Description:

Failed to retrieve information required for connecting the LUN.

LUN Name = lun21

Storage Path = /vol/xxxxx1node3_sg21l/.snapshot/eloginfo__xxxx1mail2_11-05-2010_23.30.49__daily/

Protocol Type = LUN

Storage System Name xxxxxxxxxxxxxxxx

Error code : Host (xxxxxxxxxxxxxxxxx) does not have LUN provision permission on the Storage System (xxxxxxxxxxx) Volume (xxxxx1node3_sg21l)

Event Type:        Error

Event Source:    SnapDrive

Event Category:                LUN event

Event ID:              1109

Date:                     11/18/2010

Time:                     1:24:01 PM

User:                     N/A

Computer:          xxxxxxxxxxxxxxxxxxxx

Description:

Failed to connect to LUN in a FlexClone. %8.

LUN Name = lun21

Storage Path = /vol/xxx1node3_sg21d/.snapshot/exchsnap__xxxx1mail2_11-04-2010_23.30.56__daily/

Protocol Type = LUN

Storage System Name = xxxxxxxxxxxxxxxxx

Requested Mount Point = Current user (ST\exadmin) is not allowed to perform this operation (SD.SnapShot.Clone) on this resource (xxxxxxxxxxxx:/vol/Safex1node3_sg21d).

Assigned Mount Point = %6

Error code : %7