Subscribe
Accepted Solution

SnapDrive problem - unable to find API

[ Edited ]

Hi everyone,

 

We are currently deploying a new backup solution for our service, for a better render of Hyper-V backups and I had some trouble with SnapDrive. Note that the snapdrive account has admin rights on my netapp filer.

The problem occurs when I want to create a LUN with the "Create Disk Wizard", the first step is to add the Storage System so I put the storage system name then I press "Add" and bam I always get the same error "Failed to retrieve the root volume name from the storage system (xxxxxx). Error code : 13005. Error description :  Unable to find API : volume-get-root-name". I already checked on my storage system that the root volume exists and he does. 

 

So I'm requesting your help guys, maybe be some of you already experienced that.

 

Thanks in advance

 

Re: SnapDrive problem - unable to find API

Hi,

if you are in Cdot environment in the storage controller info of the SnapDrive you must enter the ip/user about the SVM that you are tring to log in.

 

So if you have a management lif of the SVM you must put in that ip.

 

Please tell me if this works successfully.

 

Regards

Roberto

Re: SnapDrive problem - unable to find API

[ Edited ]

Yes, you're right we are in a clustered environment, I already registered those informations in SnapDrive but nothing changes.  And we don't have management LIFs, so i'm kind of blocked :/

Re: SnapDrive problem - unable to find API

[ Edited ]

Hi,

you can try to follow these documents to do the correct procedure:

 

https://library.netapp.com/ecm/ecm_download_file/ECMP1804825

https://kb.netapp.com/support/index?page=content&id=1014912&actp=RSS

 

 

Let me know

Regards

Roberto

 

PS. Pay attention to the correct username vsadmin and not admin

PS2. Also the PTR record in DNS is needed

Re: SnapDrive problem - unable to find API

[ Edited ]

This could be because of a BUG - 786228

 

More details here.

https://kb.netapp.com/support/index?page=content&id=2019826

 

If you cannot access this, please open a support case and refer to this KB ID 2019826.

The procedure involves privileged commands that has to be executed under guidance from NetApp support.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Cannot find the answer you need? No need to open a support case - just CHAT and we’ll handle it for you.

Re: SnapDrive problem - unable to find API


georgevj wrote:

This could be because of a BUG - 786228

 

More details here.

https://kb.netapp.com/support/index?page=content&id=2019826

 

If you cannot access this, please open a support case and refer to this KB ID 2019826.

The procedure involves privileged commands that has to be executed under guidance from NetApp support.


Hi,

 

thanks for your answer, unfortunately when I tried to open a case, it says that I can't because of my contract expired.

 

@ghislanzoni

 

I followed both of the procedures and I always got the same message.

Re: SnapDrive problem - unable to find API

Oh. That sounds sad, but I hope you can still get the contract renewed.?

 

However, just to make sure that this is the issue, please try the following commands from cluster shell: (NB: login to the node management interface of each node separately and run these commands on every node.)

 

CLUSTER1::> set diag

CLUSTER1::*> debug smdb table cluster_cj_status show
create-join can-switch complete message                   cluster-uuid                         sitelist-uuid
----------- ---------- -------- ------------------------- ------------------------------------ ------------------------------------
join        no         no       "Past point of no return" ce9d7980-c799-11e2-9fcd-123478563412 ce9d7980-c799-11e2-9fcd-123478563412

 

If you see a 'no' under the "complete" header, this is the issue. Then you will have to rejoin that node back to the cluster. I would not post the instructions here, since it has to be run in realtime, seeing the response of each command. Especially if this is under production. 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Cannot find the answer you need? No need to open a support case - just CHAT and we’ll handle it for you.

Re: SnapDrive problem - unable to find API


georgevj wrote:

Oh. That sounds sad, but I hope you can still get the contract renewed.?

 

However, just to make sure that this is the issue, please try the following commands from cluster shell: (NB: login to the node management interface of each node separately and run these commands on every node.)

 

CLUSTER1::> set diag

CLUSTER1::*> debug smdb table cluster_cj_status show
create-join can-switch complete message                   cluster-uuid                         sitelist-uuid
----------- ---------- -------- ------------------------- ------------------------------------ ------------------------------------
join        no         no       "Past point of no return" ce9d7980-c799-11e2-9fcd-123478563412 ce9d7980-c799-11e2-9fcd-123478563412

 

If you see a 'no' under the "complete" header, this is the issue. Then you will have to rejoin that node back to the cluster. I would not post the instructions here, since it has to be run in realtime, seeing the response of each command. Especially if this is under production. 


Thanks for the fast answer, so I run the command over all nodes separately and fortunately I got "yes" on all nodes, but unfortunately it doesn't tell us the problem though.

Re: SnapDrive problem - unable to find API

Do you have already completed the documents that I 've posted in the first answers?

I think that the solution is inside it.

 

Regards

Roberto

Re: SnapDrive problem - unable to find API

Then its a different issue.. will try to see if there is any other possibilities.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Cannot find the answer you need? No need to open a support case - just CHAT and we’ll handle it for you.