Subscribe
Highlighted

SnapVault + SMVI with Script fails

In my testing environment with a primary FAS270 and a secondary FAS3020 both with

DataOnTap 7.3.3 I have problems running scripts in SMVI 2.0 which I want to use for SnapVault.

The SMVI machine is a Windows 2003 Host.

If I take snapshots using SMVI on my NFS share with VMWare guests without using a script

everything is fine. But if I want to use a script even if the script only contains an echo command

I get the following error in the log file.

2010-11-22 09:38:43,304 [backup:b3105bc693a4efbd69b1e20339911654:] ERROR - FLOW-11019: Failure in ScriptExecutionTask: java.lang.reflect.UndeclaredThrowableException
java.lang.reflect.UndeclaredThrowableException
    at $Proxy88.retrieveProperties(Unknown Source)
    at com.netapp.smvi.task.vmware.util.VirtualMachineUtil.queryVm(VirtualMachineUtil.java:60)
    at com.netapp.smvi.task.vmware.util.VirtualMachineUtil.getVirtualMachinePowerState(VirtualMachineUtil.java:126)
    at com.netapp.smvi.task.scripting.ScriptExecutionTask.execute(ScriptExecutionTask.java:104)
    at com.netapp.common.flow.TaskInstanceTemplate.execute(TaskInstanceTemplate.java:317)
    at com.netapp.common.flow.ForLoopTemplate.execute(ForLoopTemplate.java:141)
    at com.netapp.common.flow.Operation.executeCurrentStack(Operation.java:140)
    at com.netapp.common.flow.Operation.execute(Operation.java:55)
    at com.netapp.common.flow.Threadpool$OperationThread.run(Threadpool.java:257)
Caused by: com.sun.xml.internal.messaging.saaj.SOAPExceptionImpl: No NamespaceURI, SOAP requires faultcode content to be a QName
    at com.sun.xml.internal.messaging.saaj.soap.impl.FaultImpl.setFaultCode(Unknown Source)
    at com.sun.xml.internal.messaging.saaj.soap.impl.FaultImpl.setFaultCode(Unknown Source)
    at org.apache.cxf.jaxws.JaxWsClientProxy.createSoapFault(JaxWsClientProxy.java:243)
    at org.apache.cxf.jaxws.JaxWsClientProxy.invoke(JaxWsClientProxy.java:194)

Edit: I realized, there is a new Version of SMVI called 2.0P1 which solved my problem.

Re: SnapVault + SMVI with Script fails

Hi

We have a new script that is available. Please refer the following link for more details

http://communities.netapp.com/docs/DOC-8720

REgards

Amrita